Closed Bug 1653559 Opened 6 months ago Closed 5 months ago

[V2 Doorhanger][Windows] Username dropdown arrow is not visible with High Contrast Black theme

Categories

(Toolkit :: Password Manager, defect, P2)

Desktop
Windows
defect

Tracking

()

VERIFIED FIXED
81 Branch
Tracking Status
firefox78 --- disabled
firefox79 --- disabled
firefox80 --- verified
firefox81 --- verified

People

(Reporter: andrei.purice, Assigned: severin)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image high contrast.jpg

Affected versions:
Nightly 80 - since V2 doorhanger functionality landed with Bug 1641415

Tested on:
Windows 10 / 7

Steps to reproduce:

  1. Have the High Contrast Black Windows theme set.
  2. Launch Firefox.
  3. Go to any login form, such as Facebook, Reddit etc.
  4. Fill in all the requested field (maybe edit the login form again to have multiple suggestions).
  5. Click on the dismissed doorhanger.

Expected result:
The username dropdown arrow should be visible.

Actual Result:
The username dropdown arrow is not visible at all.

Regression-range:
Not a regression since this is a new functionality.

Note:
The only high contrast theme that is not affected is High Contrast White.

Severity: -- → S4
Priority: -- → P2
Assignee: nobody → severin.mozilla
Status: NEW → ASSIGNED
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/abc829c0ca3e
fix dropmarker color on high contrast;r=MattN
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch

Verified-fixed on latest Nightly (08-11-2020) on Windows 10 with High Contrast Black theme.
The dropmarker is now properly visible.

Hey Severin, any thoughts about uplifting this to Beta or it can ride the trains?

Flags: needinfo?(severin.mozilla)

Good point, this should be safe to uplift. I'll file. Thanks Timea!

Flags: needinfo?(severin.mozilla)

Comment on attachment 9168943 [details]
Bug 1653559 - fix dropmarker color on high contrast;r=MattN

Beta/Release Uplift Approval Request

  • User impact if declined: Users on high contrast mode will not see the pmgr doorhanger dropmarker, and will likely not know that username suggestions exist.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): 2 line CSS change. It applies to a class that was added specifically for this feature, and so should not have ripple effects.
  • String changes made/needed: None
Attachment #9168943 - Flags: approval-mozilla-beta?

Comment on attachment 9168943 [details]
Bug 1653559 - fix dropmarker color on high contrast;r=MattN

approved for 80 rc1

Attachment #9168943 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified fixed in RC candidate 80 (buildID: 20200818235255) on Windows 10 x64 with High Contrast Black Theme.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.