Add menu item for "Caret Browsing (F7)"

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
--
enhancement
RESOLVED WORKSFORME
15 years ago
7 years ago

People

(Reporter: Kevin Berkheiser, Assigned: neil@parkwaycc.co.uk)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: To fix or not to fix, that is the question)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
I can't find any documentation, preference, or menu item that informs the user
of the existance of the "Caret Browsing" feature.

Please add a menu item so the user is aware of the existance of this feature.

(Mozilla 1.01 RC2)

Comment 1

15 years ago
-> aaronl
Assignee: hyatt → aaronl
Status: UNCONFIRMED → NEW
Component: XP Toolkit/Widgets: Menus → Keyboard Navigation
Ever confirmed: true
QA Contact: shrir → sairuh

Comment 2

15 years ago
Where is Mozilla's keyboard help, is another question. F7 is documented in
Netscape's kbd help. I can't figure out why Netscape has keyboard help and
Mozilla doesn't.

I'm not sure whether it should clutter the menus or not. Who do you think will
use this feature, and when?
(Reporter)

Comment 3

15 years ago
I will defer to others on this.  I never new the feature existed until I read
about it in another bug.  

I thought it was cool, because sometimes when I am browsing a long documet its
nice to have something to refocus you if you look away.  

If adding it to the menu is not a good idea, then maybe a pref.  I don't think
there should be feautures that the user can't discover from a menu or pref. 
Most users, including me, don't read the documentation, we just learn it on our own.
see also bug 128025.
OS: Windows XP → All
Hardware: PC → All
(Reporter)

Comment 5

14 years ago
Created attachment 138254 [details]
Firebird pref
(Reporter)

Comment 6

14 years ago
Firebird has a pref for this.  Since Firebird will eventually become the primary
Mozilla.org browser, I'm satisfied that this bug is now resolved.

Comment 7

14 years ago
kevin: are you sure that checkbox does what you think f7 does? i can't imagine
it does.
Assignee: aaronlev5 → neil.parkwaycc.co.uk
Severity: normal → enhancement
Component: Keyboard: Navigation → XP Apps: GUI Features
Whiteboard: To fix or not to fix, that is the question
(Assignee)

Comment 8

14 years ago
CC'ing Help owner to double-check on documentation status.

Comment 9

14 years ago
Neil, there is no documentation on Caret browsing other than a keyboard
shortcut, and no plans to create any as of now. If you would like to make some,
go right ahead!

Daniel Wang might be interested in making some documentation, if you don't have
anybody to write it.

Now if you're talking Firebird Help (which is outside of Help Systems), there is
some documentation on the prefs in the prefs.xhtml help file, if you want to use
that as a base, go right ahead! It is documentation David Tenser contributed to
FB Help Viewer from his Firefox Help site.
Product: Core → Mozilla Application Suite

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design

Comment 10

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 11

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → EXPIRED

Comment 12

7 years ago
Caret browsing preferences are now in Advanced->Keyboard Navigation->Browse with Caret (SeaMonkey 2.1pre)
Resolution: EXPIRED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.