Closed Bug 1653868 Opened 4 years ago Closed 4 years ago

CSS single-space property value incorrectly marked as invalid in devtools

Categories

(DevTools :: Inspector, defect)

77 Branch
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1630488

People

(Reporter: trusktr, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.97 Safari/537.36

Steps to reproduce:

VIsit https://codepen.io/trusktr/live/c9c98466ca6da62aaba146e9f23cad62

Right click, inspect the red element.

Actual results:

In devtools the --foo CSS property is incorrectly marked as invalid with a yellow hazard/caution/warning symbol.

Expected results:

It should not be marked invalid, because space values are valid per CSS spec.

For more info, see this short discussion: https://twitter.com/James0x57/status/1283906181031960576

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Inspector
Product: Firefox → DevTools
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.