[RFE] Change cursor based on link behavior

RESOLVED DUPLICATE of bug 14027

Status

--
enhancement
RESOLVED DUPLICATE of bug 14027
17 years ago
14 years ago

People

(Reporter: ryan_mcloughlin, Assigned: mpt)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Briefly, I want to know by the look of the cursor what is going to happen when 
I left click a link over which I'm hovering based on my prefs, the modifier 
keys, and the properties of link itself.

In more detail:

I'm a tab guy, and I don't like it when I have a bunch open and then I click 
on a link and a new window pops up in front.  I'm not talking about javascript 
windows.

I'd like it if Mozilla would signal me, preferably by changing the cursor 
(maybe have a little "W" below and to the right of the hand) when I'm hovering 
over a link that is going to pop up a window.

If, while hovering over a link, I hold down the key that makes the window open 
as a tab or a window based on my other prefs, I'd like a little "T" or "W" 
next to the cursor as appropriate.

And, as a solution to bug 90213, I'd like to have the cursor have a little "M" 
next to it when I'm hovering over mailto: links.

The center button on unix doesn't apply, this is for left clicking only.

Comment 1

17 years ago
see bug 14027 comment 35 for changing the cursor when the link will open a new
window.

*** This bug has been marked as a duplicate of 14027 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.