All users were logged out of Bugzilla on October 13th, 2018

configure script broken due to unquoted MOZ_ENABLE_GTK2 check

RESOLVED FIXED

Status

RESOLVED FIXED
16 years ago
a year ago

People

(Reporter: Mitch, Assigned: netscape)

Tracking

Trunk
Sun
SunOS

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla's configure script is broken due to the new MOZ_ENABLE_GTK2
evaluating to NULL if not set (at least it is broken with the standard
bourne shell on Solaris)

A ./configure fails thus (added -x to the start of the script):

MOZ_STATIC_COMPONENT_LIBS=
+ test  = set             
+ test  = set
+ test -z 1  
+ test -n 1
+ test -n  
+ test  = set
+ test  = set
+ test -n    
BUILD_MODULES=all
+ test  = set
+ test all != all
SKIP_IDL_CHECK=no
+ test           
+ test  = set
+ test no = no
+ test = 1    
./configure: test: argument expected


this is part of this block in the configure file:


if test "$SKIP_IDL_CHECK" = "no"
then                            
    if test $MOZ_ENABLE_GTK2 = 1; then
        # Check whether --with-libIDL-prefix or --without-libIDL-prefix was gi!
if test "${with_libIDL_prefix+set}" = set; then                                
  withval="$with_libIDL_prefix"                
  libIDL_config_prefix="$withval"
else                             
  libIDL_config_prefix=""
fi                       
  
The simple fix is to quote the MOZ_ENABLE_GTK2 like so it looks like

    if test "$MOZ_ENABLE_GTK2" = 1; then

Comment 1

16 years ago
This is a regression from the patch for bug 156593. Your patch seems to
be ok. I have another patch for this bug in an attachment for bug 156593
Fixed by owners of bug 156593.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey

Comment 3

a year ago
The configure failure has been the logical trends that can be http://printcalendartemplates.com/november-2017-printable-calendar/
variable of the logical segment
You need to log in before you can comment on or make changes to this bug.