Last Comment Bug 165508 - Telugu Font Not supported.
: Telugu Font Not supported.
Status: RESOLVED DUPLICATE of bug 59611
: intl
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: x86 All
: -- normal with 2 votes (vote)
: ---
Assigned To: Roy Yokoyama
: Yuying Long
: Makoto Kato [:m_kato]
Mentors:
http://www.eenadu.net/
: 250059 264420 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-29 10:37 PDT by Dr. SVL Narasimham
Modified: 2005-06-03 13:39 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Dr. SVL Narasimham 2002-08-29 10:37:06 PDT
Telugu is an Indian language, spoken by about 80 million people. There is a news
paper called EEnadu (meaning 'today' in Telugu) which opened a website as
http://www.eenadu.net
It is seen correctly in Explorer (unfortunately I had to use it now), but not
seen properly in Mozilla. Infact, the site gives the font help link where one
can downlad the font the paper uses. Can somebody attend to this problem?
Yours Sincerely 
Dr. SVL Narasimham
Associate Professor in Electrical & Electronics Engineering
Jawaharlal Nehru Technological University
College of Engineering
KAKINADA - 533 003
Andhra Pradesh
India
Comment 1 Arthur 2002-08-29 12:19:10 PDT
I don't see Telugu character on linux 1.1 either (not that I could read them if
they were there). Neither in the http-header nor in the html <head>-part do I
find anything regarding the desired character encoding/decoding. What I do see
are <font face='Eenadu'>-tags. The webpage is probably trying to load a font
that mozilla doesn't know. The fonts I have on my system include several UTF-8
font ranges (like Chinese, Arabic, Japanese etc.), but they don't seem to
include the Telugu characters. You could probably try to play with your mozilla
settings as explained at:

http://www.hclrss.demon.co.uk/unicode/mozilla.html

I'm still not sure whether this is a fonts problem, a problem with mozilla or
with the website.
Comment 2 Arthur 2002-08-29 12:31:13 PDT
http://www.hclrss.demon.co.uk/unicode/unicode_samples_utf8.html
is a good page to check for unicode-capabilities. Looking at this page, I think
it's a font-problem. If you have a font on your system which has complete UTF-8
support, you could try to tell mozilla to use it.
Comment 3 Niklas Dougherty 2002-08-29 12:34:00 PDT
It is a problem with the website. They use TrueDoc and other portable fonts with
special characters wrapped in a regular 8-bit encoding (not specified by page or
server, which is an error in itself). Supposing ISO-8859-1, an A is always an A,
not a dingbat or another special char.

The site should use Unicode to display Telugu.
http://www.alanwood.net/unicode/telugu.html should suffice as an example. Fonts
for Telugu (in Unicode) can be found at
http://www.alanwood.net/unicode/fonts.html#telugu

Whether Mozilla should support TrueDoc is another bug.
Comment 4 Radhakrishna Mohan Tadepalli 2002-09-06 12:34:39 PDT
This web site was display properly with Netscape 4.0, Netscape 4.7 in Microsoft
windows NT. Netscape 6.0 and Mozilla are not working. It looks like some thing
is missing between Netscape 4.7 and Netscape 6.0/Mozilla. I really appreciate if
somebody look at this problem.
Comment 5 Krsna Dasa Kavi Raju 2004-05-31 04:49:20 PDT
Do we need to support these dynamic fonts? 
instead we should go for utf8 support and can ask eenadu to support unicode. 
What do u say guys? 

Regarding unicode font support for telugu I was able to see but font rendering
is not OK, so we must first correct the rendering bug for telugu font. 

I remember some time back yudit (www.yudit.org) has also same bug but then
corrected ok, now the rendering for telugu font in yudit is superb, can we take
help from those code bits? 
Comment 6 Jo Hermans 2004-07-06 12:16:09 PDT
*** Bug 250059 has been marked as a duplicate of this bug. ***
Comment 7 Jo Hermans 2004-10-14 15:58:07 PDT
*** Bug 264420 has been marked as a duplicate of this bug. ***
Comment 8 Dr. SVL Narasimham 2004-12-09 01:19:29 PST
I just loaded fedora core 3 with firefox 1.0. I added the eenadu.ttf
(eenadu.net) and vaartha.ttf (vaartha.com) with KDE's Font Installer
(start->Control Centre->System Administration->Font Installer->Add Font). Now I
could see both the  Papers in Telugu. Eenadu fonts are showing a - (dash) in
some places where it is supposed to be a space. But for all practical purposes
it is OK and the bug may be colsed.
Comment 9 Jason Bassford 2004-12-09 04:31:30 PST
Nothing in Mozilla itself was broken or fixed.

-> WORKSFORME.
Comment 10 timeless 2005-06-03 13:39:39 PDT

*** This bug has been marked as a duplicate of 59611 ***

Note You need to log in before you can comment on or make changes to this bug.