Closed Bug 165536 Opened 19 years ago Closed 19 years ago

<input type=file> does not apply certain CSS attributes like other <input> fields

Categories

(Core :: Layout: Form Controls, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 52500

People

(Reporter: obry2k, Assigned: john)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826

<input type=file> does not apply CSS attribute such as:

font-family: Arial, Helvetica;
font-size: 8pt;
height: 18px;

These attributes (and probably others) work with the <input
type=text|submit|button|etc> form items but not with "file"...


Reproducible: Always

Steps to Reproduce:
1. Create new HTML document (in the composer for instance).
2. Add the following html:
<html><head><title>Test</title>
<style type="text/css">
.InputText { font-family: arial; font-size: 8pt; }
</style>
</head><body>
<form>
File: <input type="file" class="InputText" name="file"><br>
Text: <input type="text" class="InputText" name="text">
</form>
</body>
</html>

3. Save the file and open it in mozilla - compare how moz renders the two form
fields.




Even without any styles applied to it the file field is still bigger than a
regulatr text input field (has extra 2-3 pixels padding on the bottom)
Isn't this a dupe of bug 52500 ?

*** This bug has been marked as a duplicate of 52500 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.