Closed Bug 1655836 Opened 2 years ago Closed 2 years ago

[wpt-sync] Sync PR 24788 - Added 9 new active-selection-* tests and their references

Categories

(Core :: Layout: Generated Content, Lists, and Counters, task, P4)

task

Tracking

()

RESOLVED FIXED
81 Branch
Tracking Status
firefox81 --- fixed

People

(Reporter: mozilla.org, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 24788 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/24788
Details from upstream follow.

Gérard Talbot <github@gtalbot.org> wrote:

Added 9 new active-selection-* tests and their references

This PR is a followup to
https://github.com/web-platform-tests/wpt/pull/21928
and it has all the corrections requested and suggestions proposed in it.

active-selection-001-manual.html
active-selection-002-manual.html
active-selection-003-manual.html
active-selection-004-manual.html
active-selection-011.html
reference/active-selection-011-ref.html
active-selection-012.html
reference/active-selection-012-ref.html
active-selection-014.html
reference/active-selection-014-ref.html
active-selection-016.html
reference/active-selection-016-ref.html
active-selection-018.html

support/select-custom.png
support/select-custom.cur

{

A few comments:

  • Suggest using aqua or fuchsia text instead of black in active-selection-002-manual so that we are a bit more sure that it is not the OS default colors or some other thing that is not the actual color of the text.

  • I don't see how 19 isn't a duplicate of 17, just with different colors.

  • Also, I'm also not quite convinced that we need all of the partial test cases, probably keeping only 16 (being the most rigorous since its partial selection is in the middle) is adequate.

}

@fantasai ,
aqua text instead of black in active-selection-002-manual has been used
active-selection-016 has been kept; 015, 017 and 019 have been removed.

Please note that this PR endorses, complies and meets all of your feedbacks in
https://github.com/web-platform-tests/wpt/pull/18213
https://github.com/web-platform-tests/wpt/pull/20800
and in
https://github.com/web-platform-tests/wpt/pull/21928

Component: web-platform-tests → Layout: Generated Content, Lists, and Counters
Product: Testing → Core

CI Results

Ran 6 Firefox configurations based on mozilla-central, and Firefox, Chrome, and Safari on GitHub CI

Total 5 tests

Status Summary

Firefox

PASS: 3
FAIL: 2

Chrome

PASS: 2
FAIL: 3

Safari

PASS: 2
FAIL: 3

Links

Gecko CI (Treeherder)
GitHub PR Head
GitHub PR Base

Details

New Tests That Don't Pass

/css/css-pseudo/active-selection-014.html: FAIL (Chrome: FAIL, Safari: FAIL)
/css/css-pseudo/active-selection-018.html: FAIL (Chrome: FAIL, Safari: FAIL)

Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/29e3f1bc4d47
[wpt PR 24788] - Added 9 new active-selection-* tests and their references, a=testonly
https://hg.mozilla.org/integration/autoland/rev/f81cde9b7e21
[wpt PR 24788] - Update wpt metadata, a=testonly
You need to log in before you can comment on or make changes to this bug.