Closed Bug 1656034 Opened 1 year ago Closed 1 year ago

Support creating GLContextEGLs on different EGLDisplays

Categories

(Core :: Graphics, task, P1)

task

Tracking

()

RESOLVED FIXED
81 Branch
Tracking Status
firefox81 --- fixed

People

(Reporter: jgilbert, Assigned: jgilbert)

References

(Blocks 1 open bug, Regressed 2 open bugs)

Details

Attachments

(2 files)

This is needed in order for WebGLParent to run properly while in the same process as WR.

Priority: -- → P1
Blocks: remote-webgl

Have webrender use its own EGLDisplay, letting WebGL use a different
one.

Attachment #9167182 - Attachment description: Bug 1656034 - Add EnumValue() to mfbt. - → Bug 1656034 - Add UnderlyingValue() to mfbt. -
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fab3013d0759
Add UnderlyingValue() to mfbt. - r=froydnj
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

This is the most recent try push:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=989596f502694a38ddf3cf2fd776785e10d90744

Aside from gli/tier-2 failures it's looking good.

Flags: needinfo?(robert.mader)
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/06538f141210
Support multiple EglDisplays per GLLibraryEGL. r=lsalzman,sotaro,stransky
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f1f10f791e99
Support multiple EglDisplays per GLLibraryEGL. r=lsalzman,sotaro,stransky
Flags: needinfo?(robert.mader)
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/192bcaecf269
Support multiple EglDisplays per GLLibraryEGL. r=lsalzman,sotaro,stransky
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Regressions: 1658035

I'm not sure how significant it is but ever since this commit I'm getting the following messages (Wayland, Intel HD 4600):
Can't find symbol 'eglGetNativeClientBufferANDROID'.
Can't find symbol 'eglQuerySurfacePointerANGLE'.
Can't find symbol 'eglCreateStreamProducerD3DTextureANGLE'.
Can't find symbol 'eglStreamPostD3DTextureANGLE'.

(In reply to ileantac from comment #13)

I'm not sure how significant it is but ever since this commit I'm getting the following messages (Wayland, Intel HD 4600):
Can't find symbol 'eglGetNativeClientBufferANDROID'.
Can't find symbol 'eglQuerySurfacePointerANGLE'.
Can't find symbol 'eglCreateStreamProducerD3DTextureANGLE'.
Can't find symbol 'eglStreamPostD3DTextureANGLE'.

Expected and benign, but we should quiet these down.

Flags: needinfo?(jgilbert)
Regressions: 1658425
Regressions: 1675999
You need to log in before you can comment on or make changes to this bug.