The dtoa test (optimized build) fails on Red Hat Linux 7.2

RESOLVED DUPLICATE of bug 175668

Status

RESOLVED DUPLICATE of bug 175668
16 years ago
16 years ago

People

(Reporter: wtc, Assigned: wtc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: qa)

(Assignee)

Description

16 years ago
The dtoa test (optimized build only) fails on Red Hat Linux 7.2.
It does not fail on Red Hat Linux 6.2.

% ./dtoa
Failed to convert numeric value 1.867e73
Failed to convert numeric value -1.867e73
Failed to convert numeric value -1.867e-73
Failed to convert numeric value -1.0000000001e-21
FAILED
(Assignee)

Updated

16 years ago
Whiteboard: qa
(Assignee)

Comment 1

16 years ago
With the zone allocator engaged (setenv NSPR_USE_ZONE_ALLOCATOR 1),
the dtoa test fails with different output.

% ./dtoa
Failed to convert numeric value 10000.000000 :000
Failed to convert numeric value 1.867e73
Failed to convert numeric value -1.867e73
Failed to convert numeric value -1.867e-73
Failed to convert numeric value 1000000000099999940608.000000 :00000000100000000
000
Failed to convert numeric value -1.0000000001e-21
FAILED
(Assignee)

Comment 2

16 years ago
I confirmed that after I backported the "YES_ALIAS" fix from
the current version of dtoa.c, our dtoa test (optimized build)
passes on Red Hat Linux 7.3.  So I am pretty sure this test
failure is caused by bug 175668.

*** This bug has been marked as a duplicate of 175668 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.