Closed Bug 1656713 Opened 2 years ago Closed 2 months ago

Files and directories won't open directly from Firefox Snap

Categories

(Core :: Widget: Gtk, defect, P3)

80 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1772063

People

(Reporter: jonty.68, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:80.0) Gecko/20100101 Firefox/80.0

Steps to reproduce:

  1. Save a file from the web
  2. Click the file or click "Open Containing Folder"

Actual results:

Nothing pops up

Expected results:

File/directory should open using their respecting applications, such as Gwenview and Dolphin in my case.

Component: Untriaged → File Handling
Summary: Firefox Snap won't open files nor the directory directly from Firefox → Files and directories won't open directly from Firefox Snap

:stransky, are you the right person to ask about these types of issues? Seems specific to Snap...

Component: File Handling → Widget: Gtk
Flags: needinfo?(stransky)
Product: Firefox → Core

(In reply to :Gijs (he/him) from comment #1)

:stransky, are you the right person to ask about these types of issues? Seems specific to Snap...

No, I don't use Ubuntu/Snap. I guess it's a kind of snap sandboxing issue here, better to ask someone from Ubuntu/Canonical. Better to move such Ubuntu specific but to Ubuntu BZ - https://bugs.launchpad.net/ubuntu/

Flags: needinfo?(stransky)
Priority: -- → P3

:jlorenzo, I'm told you might know about our Snap efforts and who to ping about this issue?

Flags: needinfo?(jlorenzo)

Thanks for filing this bug, jonty.68, and looping me in, :Gijs!

This bug looks very similar to bug 1652941. jonty.68, could you run snap run firefox and tell me if you any error message when you click the "Open Containing Folder" button?

Flags: needinfo?(jlorenzo) → needinfo?(jonty.68)
See Also: → 1652941

(In reply to Johan Lorenzo [:jlorenzo] from comment #4)

Thanks for filing this bug, jonty.68, and looping me in, :Gijs!

This bug looks very similar to bug 1652941. jonty.68, could you run snap run firefox and tell me if you any error message when you click the "Open Containing Folder" button?

In every instance I clicked "Open containing folder", it kept trying to open VS Code, and when I click an image, it kept trying to open Brave

$ snap run firefox
Gtk-Message: 04:35:47.790: Failed to load module "colorreload-gtk-module"
Gtk-Message: 04:35:47.790: Failed to load module "appmenu-gtk-module"
Sandbox: /tmp/.X11-unix/X0 is inaccessible (No such file or directory); can't isolate network namespace in content processes
env: ‘/snap/bin/code’: Permission denied
env: ‘/snap/bin/code’: Permission denied
env: ‘/snap/bin/code’: Permission denied
env: ‘/snap/bin/brave’: Permission denied
env: ‘/snap/bin/brave’: Permission denied
Flags: needinfo?(jonty.68)

That's odd! I tried to reproduce this issue. On my fresh Ubuntu 18.04, nautilus opens up when I click "Open containing folder". In my case, I downloaded a tar.bz2 file[1] and I was asked what application I wanted to use. I chose the archive manager and it worked fine.

I'm surprised it tried to open VS Code or Brave. That's not the default behavior. What happens when you open the same image from nautilus?

[1] It was actually Firefox from our official website.

Flags: needinfo?(jonty.68)

I have the same issue and I noticed that if I open a file/tar it works fine the problem seems to be related to opening with other applications. For example, if I click a torrent file to open with qBittorrent will only try to load and the stop, this also happens with other applications and also snap:// doesn't open ubuntu store, it does nothing.

I'm sorry, I don't manage to repro on a fresh ubuntu. Here's how I got the latest Firefox to open a snap:// link: https://drive.google.com/file/d/1PU6hWBFYBgp_WQe3yNVVl-jZz7HkFvZx/view

Can you both show me what happens on your side?

Sorry for delayed reply.
(In reply to Johan Lorenzo [:jlorenzo] from comment #6)

That's odd! I tried to reproduce this issue. On my fresh Ubuntu 18.04, nautilus opens up when I click "Open containing folder". In my case, I downloaded a tar.bz2 file[1] and I was asked what application I wanted to use. I chose the archive manager and it worked fine.

I'm surprised it tried to open VS Code or Brave. That's not the default behavior. What happens when you open the same image from nautilus?

[1] It was actually Firefox from our official website.

I'm using Plasma so I use Dolphin. For images, Firefox installed from Apt, the "Open Containing Folder" opens Dolphin, and the image itself opens Gwenview. Snap version doesn't do anything.

I tried downloading a ZIP file. I tried to open up the file directly and saving the file. The former worked perfectly, while the latter failed miserably.

Flags: needinfo?(jonty.68)

I wonder if you need [1], similarly to bug 1652941 comment 7. That said, xdg-desktop-portal-kde seems to be in active development[2]. Ken, is KDE + Snap supported on Ubuntu?

[1] https://packages.ubuntu.com/focal/xdg-desktop-portal-kde
[2] https://github.com/flatpak/xdg-desktop-portal#using-portals

Flags: needinfo?(ken.vandine)

For me it seems the problem is solved on latest firefox snap

(In reply to Johan Lorenzo [:jlorenzo] from comment #10)

I wonder if you need [1], similarly to bug 1652941 comment 7. That said, xdg-desktop-portal-kde seems to be in active development[2]. Ken, is KDE + Snap supported on Ubuntu?

[1] https://packages.ubuntu.com/focal/xdg-desktop-portal-kde
[2] https://github.com/flatpak/xdg-desktop-portal#using-portals

Yes xdg-desktop-portal-kde is supported. It should be installed by anyone with plasma-discover-backend-snap, which kubuntu and neon should have.

Anyone with this issue, please comment with the output of this:

snap version

Flags: needinfo?(ken.vandine)

Firefox version 90.0b6

$ snap version
snap    2.50.1
snapd   2.50.1
series  16
neon    20.04
kernel  5.11.0-7614-generic
Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1772063
You need to log in before you can comment on or make changes to this bug.