Closed Bug 1656887 Opened 2 years ago Closed 2 years ago

Print job can no longer be initiated via Print setup for a local page if the "preparing dialog" was closed before the "Save print output as" prompt

Categories

(Core :: Printing: Output, defect, P3)

All
Windows 10
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr68 --- wontfix
firefox-esr78 --- wontfix
firefox79 --- wontfix
firefox80 --- wontfix
firefox81 --- fixed
firefox82 --- fixed
firefox83 --- fixed

People

(Reporter: emilghitta, Unassigned)

References

Details

(Whiteboard: [layout:print-triage:p2][print2020_v81][Fixed by 1636728])

Affected versions

  • 81.0a1 (BuildId:20200727203201)
  • 80.0b3 (BuildId:20200803045446)
  • 79.0 (BuildId:20200720193547)
  • 78.1.0esr (BuildId:20200722151235)
  • 68.11.0esr (BuildId:20200720181548)

Affected platforms

  • Windows 10 64bit

Unaffected platforms

  • Ubuntu 18.04 64bit
  • macOS 10.14

Steps to reproduce

  1. Launch Firefox.
  2. Access the about:support page.
  3. Hit CTRL + P
  4. Select the print to PDF option.
  5. Click the Print button.
  6. Click the X button from the preparing dialog before the “Save print output as” prompt is displayed (or press the escape button before the “Save print output as” prompt is displayed).
  7. Repeat step 3.

Expected result

  • The print setup is properly displayed and the print job can be successfully initiated.

Actual result

  • Print preview error. Some printing functionality is not currently available.

The following error is displayed inside the browser console:
Uncaught (in promise) Exception { name: "NS_ERROR_NOT_AVAILABLE", message: "", result: 2147746065, filename: "chrome://global/content/elements/browser-custom-element.js", lineNumber: 1718, columnNumber: 0, data: null, stack: "print@chrome://global/content/elements/browser-custom-element.js:1718:31\nprintWindow@chrome://global/content/printUtils.js:297:16\nstartPrintWindow@chrome://global/content/printUtils.js:255:12\noncommand@chrome://browser/content/browser.xhtml:1:12\n", location: XPCWrappedNative_NoHelper } Browser-custom-element.js:1718

Regression Range

  • The issue seems to be reproducible on older builds as well (54.0a1)

Notes

  • This seems to affect only the tab where this issue was initially reproduced in.
  • This seems to be reproducible only on local pages.
  • Restarting Firefox or opening the print preview in that particular tab seems to fix this behavior.
  • [Suggested Severity] I think that S3 fits for this issue.
See Also: → 1656892
Severity: -- → S3
Priority: -- → P3
Whiteboard: [layout:print-triage:p2][print2020]
Has STR: --- → yes

I am unable to reproduce this issue any longer.

This seems to may have been fixed by Bug 1636728 (per the following Pushlog: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=2969f3de028f013d30ea20bfccc13670ef8e195f&tochange=37183f7a2405794b679d82b279a586c0d4fb5b4f)

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Whiteboard: [layout:print-triage:p2][print2020] → [layout:print-triage:p2][print2020][Fixed by 1636728]
Whiteboard: [layout:print-triage:p2][print2020][Fixed by 1636728] → [layout:print-triage:p2][print2020_v81][Fixed by 1636728]
You need to log in before you can comment on or make changes to this bug.