Closed Bug 1657166 Opened 2 years ago Closed 2 years ago

Prevent accidently blocking images via SeaMonkey mailcontext and context popup menu.

Categories

(SeaMonkey :: Passwords & Permissions, task)

Tracking

(seamonkey2.53+ fixed, seamonkey2.57esr? affected)

RESOLVED FIXED
seamonkey 2.79
Tracking Status
seamonkey2.53 + fixed
seamonkey2.57esr ? affected

People

(Reporter: frg, Assigned: frg)

Details

(Whiteboard: SM2.53.5)

Attachments

(1 file, 1 obsolete file)

User now and then manage to block images via the popup menu. The block and unblock items are just too near to view and copy image and if you are a bit careless this happens.
I think moving them under a separater should fix this for almost all cases. Some users might still need them so we donÄt want to remove the items.

Also a comment in the mailcontext popup states wrongly that this is not used and the enable/disable code there causes the exact problems mentioned with working only on second open so update this too.

Whiteboard: SM2.53.5
Attached patch 1657166-blockimagesep-2535.patch (obsolete) — Splinter Review

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: support issues/calls with broken websites
Testing completed (on m-c, etc.): 2.53.5
Risk to taking this patch (and alternatives if risky): moderate so lets not take it to 2.53.4
String changes made by this patch: none

Attachment #9167950 - Flags: review?(iann_bugzilla)
Attachment #9167950 - Flags: approval-comm-release?
Attachment #9167950 - Flags: approval-comm-esr60?
Comment on attachment 9167950 [details] [diff] [review]
1657166-blockimagesep-2535.patch

>+++ b/suite/mailnews/content/mailContextMenus.js
>+/**
>+ * Hide a separator based on whether there are any non-hidden items between
>+ * it and the previous separator.
>+ *
>+ * @param aSeparatorID  The id of the separator element.
>+ */
>+function hideIfAppropriate(aSeparatorID) {
>+  ShowMenuItem(aSeparatorID, shouldShowSeparator(aSeparatorID));
Can we not just make use of the nsContextMenu's shouldShowSeparator function here rather than having a duplicate one in mailnews?

r/a=me with that addressed
Attachment #9167950 - Flags: review?(iann_bugzilla)
Attachment #9167950 - Flags: review+
Attachment #9167950 - Flags: approval-comm-release?
Attachment #9167950 - Flags: approval-comm-release+
Attachment #9167950 - Flags: approval-comm-esr60?
Attachment #9167950 - Flags: approval-comm-esr60+

Version 1.1. Use shouldShowSeparater from nsContextMenu.js and update its comment and body (var -> let).

r/a+ from IanN retained

Attachment #9167950 - Attachment is obsolete: true
Attachment #9169009 - Flags: review+
Attachment #9169009 - Flags: approval-comm-release+
Attachment #9169009 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/726dd53ea621
Move block image context menu items to separate entry and cleanup mail context menu handling. r=IanN

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.79
You need to log in before you can comment on or make changes to this bug.