CSS, right aligned text input, no caret on focus

RESOLVED DUPLICATE of bug 105397

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 105397
16 years ago
13 years ago

People

(Reporter: odapple, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)
Build Identifier: 1.1

"Vanilla" Red Hat 7.2, Mozilla 1.1 (8/26) Release with the Java2 plugin.

I have the following CSS line in the header,
  input.nin {text-align:right;}
I use text input fields with class="nin" for numeric input.  When these fields 
receive focus there is no caret, but they work properly in every other respect.

Reproducible: Always

Steps to Reproduce:
1. Create a web page with the a CSS spec in the header containing the line:  
  input.nin {text-align:right;}
2. Add a text input element with class="nin"
3. Load the page with Mozilla 1.1 on Red Hat 7.2
4. Move to the field

Actual Results:  
The caret disappears.

Expected Results:  
Caret on the right.

Using default fonts.  If you cannot reproduce, I can make you a test case.
(Reporter)

Comment 1

16 years ago
Build Info => Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826 - I
didn't have this info handy on first submission. 
Duplicate of 'caret not displayed for text inputs using style="text-align:
right" on first click'

*** This bug has been marked as a duplicate of 105397 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.