Closed Bug 1657630 Opened 1 year ago Closed 1 year ago

Crash in [@ wl_proxy_create_wrapper | dri2_wl_create_window_surface]

Categories

(Core :: Graphics, defect)

Unspecified
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1645677

People

(Reporter: sefeng, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug is for crash report bp-a61e2f12-57d5-488c-8dae-49fd20200804.

Top 10 frames of crashing thread:

0 libwayland-client.so.0 wl_proxy_create_wrapper src/wayland-client.c:2237
1 libEGL_mesa.so.0 dri2_wl_create_window_surface ../src/egl/drivers/dri2/platform_wayland.c:377
2 libEGL_mesa.so.0 _eglCreateWindowSurfaceCommon ../src/egl/main/eglapi.c:971
3 libxul.so mozilla::gl::CreateSurfaceFromNativeWindow gfx/gl/GLContextProviderEGL.cpp:234
4 libxul.so mozilla::gl::GLContextEGL::RenewSurface gfx/gl/GLContextProviderEGL.cpp:503
5 libxul.so mozilla::layers::CompositorBridgeParent::ResumeComposition gfx/layers/ipc/CompositorBridgeParent.cpp:738
6 libxul.so mozilla::layers::CompositorBridgeParent::RecvResumeAsync gfx/layers/ipc/CompositorBridgeParent.cpp:574
7 libxul.so mozilla::layers::PCompositorBridgeParent::OnMessageReceived ipc/ipdl/PCompositorBridgeParent.cpp:1295
8 libxul.so mozilla::layers::PCompositorManagerParent::OnMessageReceived ipc/ipdl/PCompositorManagerParent.cpp:197
9 libxul.so mozilla::ipc::MessageChannel::DispatchMessage ipc/glue/MessageChannel.cpp:2074

This seems like a crash of creating window on wayland. The number of crashes are not a lot.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1645677
You need to log in before you can comment on or make changes to this bug.