Closed Bug 1657886 Opened 2 years ago Closed 2 years ago

[macOS 11] Page view shrinks when Firefox window is moved from a screen to another

Categories

(Core :: Widget: Cocoa, defect, P2)

Desktop
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1586816
Tracking Status
firefox80 --- affected
firefox81 --- affected

People

(Reporter: csasca, Unassigned)

References

(Blocks 1 open bug)

Details

Affected versions

  • Firefox 80.0b5
  • Firefox 81.0a1

Affected platforms

  • macOS 11 (public beta 1)

Steps to reproduce

  1. Launch Firefox
  2. Access any video on youtube
  3. Drag Firefox window on the secondary display then drag it back to the primary display

Expected result

  • The page has the same size

Actual result

  • The page shrinks for a second or two then stretches back to it's original size

Regression range
I don't think this is a regression.

Additional notes

  • The issue can be seen in the following attachment.
  • Dual display is needed in order to reproduce this issue
  • It happens on all websites, but if there is a video rendering on the page (ex. youtube), the shrinked page will stay longer until it stretches back to the original size.
Blocks: 1648487
Has Regression Range: --- → no
Has STR: --- → yes
Severity: normal → --

The severity field is not set for this bug.
:alaskanemily, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(emcdonough)

Probably more of a Widget-level issue than Layout.

Component: Layout → Widget: Cocoa

This looks like it might require a fix similar to bug 1154125, which was in Layout. Is it possible that bug 1154125 has regressed? Happy to take it back in widget:cocoa if this is found to be a widget-level issue now.

Component: Widget: Cocoa → Layout

Bug 1154125 was different, in that (IIRC) the incorrect scaling was persistent until the window was manually resized (or something else triggered a re-layout), because we'd used the wrong scale factor. Here, the final state is fine, it's just an ugly transitional issue. Seems like it's probably related to how we handle resolution-change notifications from the OS; maybe there's a change in 11.0 in how/when these are dispatched or something.

Ah, thanks. We have had reports of this before, but I can't seem to find the right bug to duplicate this to at the moment. I will take another look.

Severity: -- → S3
Component: Layout → Widget: Cocoa
Flags: needinfo?(emcdonough)
Priority: -- → P2
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1586816
You need to log in before you can comment on or make changes to this bug.