Open Bug 1657900 Opened 3 years ago Updated 1 year ago

Only the CC number is captured and saved upon submit on several sites

Categories

(Toolkit :: Form Autofill, defect, P3)

Desktop
Windows
defect

Tracking

()

REOPENED
Tracking Status
firefox79 --- disabled
firefox80 --- disabled
firefox81 --- wontfix
firefox82 --- fix-optional
firefox83 --- affected
firefox84 --- affected
firefox85 --- affected
firefox86 --- affected
firefox94 --- affected
firefox95 --- affected
firefox96 --- affected

People

(Reporter: tbabos, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug, )

Details

Attachments

(1 file)

Affected version:
FX80 - if CC specific prefs are enabled

Tested on:
Windows 10

Steps to reproduce:

  1. Reach the Payment form for https://apothekeco.com/
  2. Fill in the Payment form fields and submit
  3. Check the captured info in the doorhanger and save the CC info

Expected Result:
All the form fields should've been captured and saved accrordingly. (except CVV)

Actual Result:
Only the CC number is captured and saved in a profile in the credit card storage.

Regression-range
Will look into it asap. This site was never tested before.

*Edits:
All affected sites:
https://shop.hellolumio.com
https://thegoodbatch.com
https://porterandyork.com
https://shop.economist.com
https://kkwbeauty.com
Walmart.com
Ebay.com
Wayfair (cardholder name and expiry date missing)
Lumio
Apotheke

DE Sites:
Amazon.de

UK Sites:
Ebay.co.uk

*CA Sites:
canadientire.ca
ebay.ca
walmart.ca
wayfair.ca
clementinefields.ca
1861.ca

Summary: Only the CC number is captured and saved upon submit on apothekeco.com → Only the CC number is captured and saved upon submit on several sites

Suggesting S2 severity if not S1 since the doorhanger is capturing only de CC numbers for the given sites which are P2 and P3 priorities based on https://docs.google.com/spreadsheets/d/10V0bnw5nWM52ouADYM6H89B43v2JHKZaV1m3YZ8kiw0/edit#gid=0

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Whiteboard: [ccautofill]

Similar issues happening on:

  1. Walmart.com
  2. Ebay.com
  3. Wayfair (cardholder name and expiry date missing)
  4. Lumio
  5. Apotheke

Hi Jim, can we re-open this? Bug 1657840 now addresses only the expiry date autofill aspect so doesn't look like a dupe of this anymore.

Flags: needinfo?(jmathies)
Flags: needinfo?(jmathies)
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Severity: -- → S4
Priority: -- → P3

Adding walmart.ca to affected sites lists. Reproducible on latest Firefox Nightly 85.0a1 (2020-11-17).

Adding ebay.co.uk and Amazon.de to the list of affected sites, reproduced on the latest Firefox Nightly 96.0a1 on MacOS 10.15.

Adding www.obi.de and lidl.de to the list of affected sites, reproduced on the latest Firefox Nightly 96.0a1 on Windows 10.

Raising the severity of this issue as it affects multiple sites.

Severity: S4 → S3
Depends on: 1730016

Timea and Alin,
Could you help test the sites you listed in comment 0 to find out whether we could reproduce this issue on those sites on Google Chrome?

Flags: needinfo?(timea.babos)
Flags: needinfo?(alin.ilea)

Hey Ethan,
We tested again all the sites mentioned in this issue on Chrome and the latest Firefox Nightly 97 since the US and CA sites were tested a long time ago and we needed the latest status to avoid obsolete results.

We have obtained 4 categories for the results of this check:

  • Reproducible on Firefox and Chrome as well, affected sites: Walmart.com, Lidl.de

  • Reproducible on Firefox but NOT on Chrome, affected sites: Ebay.com, Ebay.ca, Ebay.co.uk
    Important Note: reproducible on Firefox fully or partially.
    Partially: cardholder name is not displayed in doorhanger, but it is saved in storage.
    Please note that displaying the Cardholder Name in the doorhanger is not part of Chrome’s functionality. So in this case Chrome passed the test, but on Firefox is partial since we should also display the Cardholder Name in the doorhanger not just in storage.

  • Reproducible on Firefox but we couldn't confirm on Chrome since the doorhanger is not displayed at all there, affected sites: Hellolumio.com, Economist.com, Kkwbeauty.com, Wayfair.com, Wayfair.ca, Clementinefields.ca, 1861.ca, Obi.de

  • We couldn't check reproducibility since the doorhanger is not displayed in Firefox nor Chrome, affected sites: Thegoodbatch.com, Porterandyork.com, Apotheke.com, Canadiantire.ca, Walmart.ca

This check results can also be reached in the Testing Document if you would like to apply further filters or see which sites are affected fully or partially. If there is anything else we could help with, let us know.
Thanks!

Flags: needinfo?(timea.babos)
Flags: needinfo?(alin.ilea)
You need to log in before you can comment on or make changes to this bug.