Closed Bug 1657902 Opened 2 years ago Closed 2 years ago

[macOS 11] Firefox is not using dedicated gpu

Categories

(Core :: Graphics, defect, P3)

Desktop
macOS
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox80 --- fixed
firefox81 --- fixed

People

(Reporter: csasca, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image DG not detected.png

Affected versions

  • Firefox 80.0b5
  • Firefox 81.0a1

Affected platforms

  • macOS 11 (public beta 1)

Preconditions

  • A dual graphics mac is required
  • The dedicated gpu is set to active

Steps to reproduce

  1. Launch Firefox
  2. Access about:support and scroll to Graphics category
  3. See the browser console for the initialised compositor as well

Expected result

  • The dedicated gpu is in use

Actual result

  • The intel iris pro gpu is in use, despite dedicated gpu being active

Regression range

  • This is happening on macOS 11, so I don't think this is a regression.

Additional notes

  • The infos can be seen in the attachment.
  • This is reproducible on a macbook pro 2015 15" with Radeon R9 M370X dedicated gpu.
  • Firefox Nightly has Webrender by default but still uses the integrated graphics.
Has Regression Range: --- → no
Has STR: --- → yes
Summary: [macOS 11 → [macOS 11] Firefox is not using dedicated gpu
Has Regression Range: no → irrelevant

@Catalin: Do you see the same behavior with webrender on?

Severity: normal → S3
Flags: needinfo?(catalin.sasca)
Priority: -- → P3

Hey Kris, it seems that now Firefox 80.0b6 and latest nightly 81.0a1 are seeing by default the dedicated graphics. I think this is safe to close this issue.

Flags: needinfo?(catalin.sasca) → needinfo?(ktaeleman)

Thanks Catalin!

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(ktaeleman)
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.