Mozilla crashed after command+q Quit command [@ nsStyleContext::Destroy]

VERIFIED WORKSFORME

Status

()

Core
Layout
P3
critical
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Greg K., Unassigned)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1b) Gecko/20020829
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1b) Gecko/20020829

I uninstalled a theme using the Theme preferences, then pressed command+q to
quit Mozilla. Mozilla closed the open browser window, then crashed.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. Uninstall a third-party theme using the Theme preferences
2. Dismiss the Theme preferences dialog window
3. Quit Mozilla.

Actual Results:  
Mozilla crashed.

Expected Results:  
Mozilla should not have crashed.
(Reporter)

Comment 1

16 years ago
Created attachment 97342 [details]
Crash report generated by FizzillaCFM/2002082909 showing crash after nsStyleContext::Destroy

I see a lot of layout identifiers in the stack, so I'm starting there. Sorry if
that's not the right place for this.

Updated

16 years ago
Keywords: crash

Comment 2

16 years ago
Does this still happen in the latest build ? Which theme were you uninstalling ?
(Reporter)

Comment 3

16 years ago
I was uninstalling an older version of Pinstripe, probably. As I mentioned in
the original report, I couldn't reproduce this with the same build.

I submitted a bug report anyway to get the stack into the system.

Updated

16 years ago
Keywords: stackwanted
(Reporter)

Updated

16 years ago
Keywords: stackwanted
Summary: Mozilla crashed after command+q Quit command → Mozilla crashed after command+q Quit command [@ nsStyleContext::Destroy]
(Reporter)

Comment 4

16 years ago
Bug 170824 may be a duplicate of this one.

Comment 5

16 years ago
-- Unable to reproduce the crash with Mozilla 1.2a release. I tried with 2 or 3
themes. Therefore marking the priority as P3.I tried with theme Pinstripe also.
Priority: -- → P3

Comment 6

16 years ago
reassign

Greg: have you seen anything like this recently.  IIRC, some bugs related to
third-party themes have been fixed.
Assignee: attinasi → other
QA Contact: petersen → ian
(Reporter)

Comment 7

16 years ago
No, no recent occurances.
If this is not reproducible, please mark worksforme....
(Reporter)

Comment 9

15 years ago
Resolving WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

13 years ago
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsStyleContext::Destroy]
You need to log in before you can comment on or make changes to this bug.