Closed Bug 1658112 Opened 2 years ago Closed 2 years ago

"busy wheel" mouse cursor icon showing for 25 s when starting TB (in Xfce environment)

Categories

(MailNews Core :: General, defect)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1658062

People

(Reporter: fernm, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: perf)

Attachments

(2 files)

Attached image bildschirmfoto.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

TB 78.1.1

For all TB mail accounts, disable the "fetch mail on startup" option
Start TB
Go with the mouse cursor on the TB main window title bar

Actual results:

For about 25 seconds after the TB main windows has opened, the mouse cursor icon is a "busy turning wheel" (see screenshot, "busy" mouse cursor right beside the window title)
User wonders what TB would be busy on. Feeling of uncertainty.

Nevertheless, user can work with TB (e.g. reading mail). When the mouse cursor leaves the window title bar, the mouse cursor changes to the normal mouse icon (not the busy wheel icon anymore). When moving the mouse cursor back to the TB window title bar, the mouse cursor icon again changes to the busy wheel icon, until the 25 s time runs out. Then it turns to the normal mouse icon.

Expected results:

There should be a message in the bottom status message line saying what TB is busy on, so the user has not this uncertain feeling, what TB would do there.

How could I debug what TB does there?

Type: enhancement → defect
Keywords: perf

I recognized, when starting TB directly from the Bash console, there is no spinning wheel icon, all ok.
Seems to have to do with the Desktop environment "Xfce" that I use, when starting TB via a "launcher".

An Xfce launcher has the option "Startup notification" (see https://docs.xfce.org/xfce/exo/desktop-item-edit#editing_launchers). When enabled, the mouse cursor gets spinning when starting the launcher and the effect is there that it keeps spinning 25 s after TB man window has opened.
When disabling it, the mouse cursor stays normal. like when starting from Bash console.

In the attached screenshot I marked the option that when disabling it, solves this bug.

I leave the bug open for someone other to review if this is of some interest, but I think this is no TB issue and can be closed.

Attached image editing launcher

Here
https://forum.xfce.org/viewtopic.php?pid=30402#p30402
is written "Note that the application itself has to support this notification for the spinning cursor to appear."

So there might be the question if it is TB that notifies the desktop environment about having completely started (so the mouse cursor changes to normal state), and that is 25 s after main window opened and user can work, and that would be a little late?

So, if TB should be involved here with the notification, then it might be good, if the "completely started" notification to the desktop environment could be some time earlier, e.g. when main window has opened and user can start reading mail.

Here is the spec from free desktop, so it should not be Xfce specific.
https://specifications.freedesktop.org/startup-notification-spec/startup-notification-0.1.txt

Summary: "busy wheel" mouse cursor icon showing for 25 s when starting TB → "busy wheel" mouse cursor icon showing for 25 s when starting TB (in Xfce environment)

Likely bug 1658062. If you still see a problem after using 78.2.0 please give a shout.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1658062

Issue is still the same with TB 78.2.0.

You need to log in before you can comment on or make changes to this bug.