Closed Bug 1658182 Opened 1 year ago Closed 1 year ago

Servo Moire Demo OOM's after bug 1641751

Categories

(Core :: Graphics: WebRender, defect)

defect

Tracking

()

RESOLVED FIXED
81 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox79 --- wontfix
firefox80 --- wontfix
firefox81 --- fixed

People

(Reporter: mayankleoboy1, Assigned: gw)

References

(Regression, )

Details

(Keywords: memory-footprint, regression)

Attachments

(2 files)

  1. Use nightly
  2. Enable WR
  3. Open http://browserhtml.github.io/browserhtml/components/about/newtab/demos/moire.html

ER: Demo does not OOM
AR: Demo will OOM after 8-10 seconds

2020-08-09T11:14:20.880000: INFO : Narrowed integration regression window from [99bf0f43, 01ccbe21] (4 builds) to [988197b0, 01ccbe21] (2 builds) (~1 steps left)
2020-08-09T11:14:20.903000: DEBUG : Starting merge handling...
2020-08-09T11:14:20.903000: DEBUG : Using url: https://hg.mozilla.org/integration/autoland/json-pushes?changeset=01ccbe217e03b2942a35a07a5cadeb02213bc73d&full=1
2020-08-09T11:14:20.903000: DEBUG : redo: attempt 1/3
2020-08-09T11:14:20.904000: DEBUG : redo: retry: calling _default_get with args: ('https://hg.mozilla.org/integration/autoland/json-pushes?changeset=01ccbe217e03b2942a35a07a5cadeb02213bc73d&full=1',), kwargs: {}, attempt #1
2020-08-09T11:14:20.912000: DEBUG : urllib3.connectionpool: Resetting dropped connection: hg.mozilla.org
2020-08-09T11:14:22.885000: DEBUG : urllib3.connectionpool: https://hg.mozilla.org:443 "GET /integration/autoland/json-pushes?changeset=01ccbe217e03b2942a35a07a5cadeb02213bc73d&full=1 HTTP/1.1" 200 None
2020-08-09T11:14:22.932000: DEBUG : Found commit message:
Bug 1641751 - Part 4 - Introduce an LRU eviction policy for the texture cache r=Bert,kvark

Previously, when we decided to evict elements from the texture cache,
a very simple scheme was used. All elements would be scanned, and
any element that was older than a given threshold would be freed.

I dont know how real world this moire demo is, and how real is this regression. Feel free to WONTFIX

Attached file about:support

Gnome Xwayland, Debian Testing
This is really bad. 2 seconds and my desktop is permanently frozen.

(General rant because it's depressing every day: My 8 content processes anyway think Firefox is VirtualBox and that it would be totally okay to use 30-800 MB each. WIthout special permission. I used to have least 10 app tabs as bookmarks because it was advertised Firefox could handle many tabs, but it feels like it regressed. It should rather be slightly slower than using so much memory, becoming a risk. Javascript is cancer. xD WIth 6 GB RAM I get at least one OOM per day due to Firefox and Thunderbird because they take what they can get and totally ignore Linux awful OOM handllng (freezing instead of killing processes). At the moment, Nextcloud, YouTube, Twitter, Reddit and Bugzilla lead to 1.3 GB total memory consumption of Firefox. 100 to 150 MB RAM per website (=750MB) would be acceptable to have at least some room for future tabs. Apart from the general problem, each time I want to compile something larger I anyway have to close Firefox so that my desktop doesn't die.)

Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(gwatson)
OS: Unspecified → All
Hardware: Unspecified → All
See Also: → 1457683
Assignee: nobody → gwatson
Flags: needinfo?(gwatson)
Pushed by gwatson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8a1b47a902ab
Fix texture cache items not being evicted. r=kvark
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
You need to log in before you can comment on or make changes to this bug.