Closed Bug 1658444 Opened 1 year ago Closed 1 year ago

macOS accent color is used inconsistently in print sheet

Categories

(Toolkit :: Printing, defect, P2)

Unspecified
macOS
defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox81 --- verified

People

(Reporter: yoasif, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: nightly-community, Whiteboard: [print2020_v81])

Steps to reproduce:

  1. Set macOS accent color to orange
  2. Open any web page
  3. Do command-p
  4. Open "More settings"

What happens:

macOS accent color is used for radio buttons and text boxes.

Expected result:

macOS accent color should be used for remaining widgets, like dropdown, buttons, segmented controls and focus colors.

Blocks: 133787, 1470323
Severity: -- → S4
Priority: -- → P2
Whiteboard: [print2020_v81]

Alternatively, maybe we shouldn't use the MacOS accent colour in any of those places, like about:preferences…

(In reply to Blake Winton (:bwinton) (:☕️) from comment #1)

Alternatively, maybe we shouldn't use the MacOS accent colour in any of those places, like about:preferences…

I think that would be a bad idea - this sheet is chrome, whereas if you squint a bit you can consider about:preferences to be content. Of course, I would prefer that about:preferences also use the accent colors correctly, but it is worse when it is chrome, imo.

Yes, but if it's a choice between shipping with inconsistent colours, and shipping with all blue highlights, I know which one I'd go for.

The accent colour should only be used for the text selection. We use the Firefox colours, not system colours for our UI elements. The radio buttons should no longer show the system accent colour.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1656939

(In reply to Mark Striemer [:mstriemer] from comment #4)

The accent colour should only be used for the text selection. We use the Firefox colours, not system colours for our UI elements. The radio buttons should no longer show the system accent colour.

Is that a global Firefox decision or just the print sheet? If global, that means bug 1470323 is a WONTFIX so clarification would be great.

Flags: needinfo?(mstriemer)

I'm not sure about that one. I think for form elements we want to use our Firefox colours, but for a selection (text, selected element in a dropdown) we use the system colour.

The selected element in a dropdown case there seems to just be how it's done, I don't necessarily agree with it, but that seems to be what that bug is about so it seems valid.

Flags: needinfo?(mstriemer)
Depends on: 1656939
Resolution: DUPLICATE → FIXED

Reproduced with 81.0a1 (2020-08-10) on macOS 10.15.
Verified fixed with 81.0a1 (2020-08-24) on macOS 10.15.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.