linsoft.se - Java and Mozilla hang when loading certain URLs

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
16 years ago
8 years ago

People

(Reporter: frank.carlsson, Assigned: joe.chou)

Tracking

({hang})

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
When I for example go to the link
http://www.linsoft.se/butiken/prisl/borland.htm and then click at the reload
button, Mozilla hangs. It's also possible to get the same result without pushing
the reload button, if you start at http://www.linsoft.se/butiken/index.htm and
select, for instance, Borland, at the left menu.

This should be an old bug, because (as far as I remeber) it's also happend
several month ago when I visited that site.

Sincerely,
Frank
(Reporter)

Comment 1

16 years ago
Maybe it's got something to do with java applets, when I run the top command
after several hangs i receive the following result:
 
 2475 root      25   0 26096  25M  9948 R    14,0  6,7  18:22 java_vm
 2734 root      25   0 25732  25M  9736 R    14,0  6,6  14:22 java_vm
 3577 root      25   0 26376  25M  9944 R    14,0  6,8   3:05 java_vm
 4170 root      25   0 31824  31M  9628 R    14,0  8,2   1:49 java_vm
 6815 root      25   0 29200  28M  9616 R    14,0  7,5   1:13 java_vm
 7874 root      25   0 25428  24M  9500 R    14,0  6,6   0:24 java_vm

Do I have to tell you that my computer is real slow now ;-)

By the way, if Mozilla doesn't hang the first time, keep hiting the reload button.

/Frank
(Reporter)

Updated

16 years ago
Summary: Mozilla hangs when reloadning a certain URLs → Mozilla hangs when reloading certain URLs

Updated

16 years ago
Severity: normal → critical
Keywords: hang

Comment 2

16 years ago
Which version of mozilla and JRE are you using?

Comment 3

16 years ago
I'm using BuildID 2002083005 on RH7.3 with JRE 1.4.0-b92 and it causes a hang
for me. Looking at top it generates about 69 java_vm processes and then just hangs.
Seems to work ok on Win2KSP2
Assignee: jst → joe.chou
Status: UNCONFIRMED → NEW
Component: DOM HTML → OJI
Ever confirmed: true
QA Contact: stummala → pmac
(Reporter)

Comment 4

16 years ago
I'm using "Java(TM) Plug-in 1.3.1_02-b02" and Mozilla 2002083005

/Frank
(Reporter)

Comment 5

16 years ago
Perhaps I should clearify how I get the following when issuing the top command:
 2475 root      25   0 26096  25M  9948 R    14,0  6,7  18:22 java_vm
 2734 root      25   0 25732  25M  9736 R    14,0  6,6  14:22 java_vm
                               .
                               .
I simply kill mozilla with the kill command when I discover it's lowest PID
 ps -ef | grep mozilla
 kill <pid>

I can then repeatedly start mozilla and the JVM seems to be running wild when
mozilla is killed

Comment 6

16 years ago
I've upgraded to using JRE 1.4.0_01-b03 and I still get a hang with BuildID
2002083005 on RH7.3. This is the list of processes associated with the user
running mozilla when it hangs on this site. As you can see process 1876 seems to
spawn about 80+ children.

ian       1806  1803  0 10:18 pts/1    00:00:00 -bash
ian       1846  1806  0 10:18 pts/1    00:00:00 /bin/sh /usr/local/mozilla/run-m
ian       1852  1846 16 10:18 pts/1    00:01:27 /usr/local/mozilla/mozilla-bin
ian       1854  1852  0 10:18 pts/1    00:00:00 /usr/local/mozilla/mozilla-bin
ian       1855  1854  0 10:18 pts/1    00:00:00 /usr/local/mozilla/mozilla-bin
ian       1856  1854  0 10:18 pts/1    00:00:00 /usr/local/mozilla/mozilla-bin
ian       1857  1854  0 10:18 pts/1    00:00:00 /usr/local/mozilla/mozilla-bin
ian       1865  1854  0 10:21 pts/1    00:00:00 /usr/local/mozilla/mozilla-bin
ian       1875  1852 10 10:25 pts/1    00:00:15 java_vm 
ian       1876  1875  0 10:25 pts/1    00:00:00 java_vm 
ian       1877  1876  1 10:25 pts/1    00:00:01 java_vm 
ian       1878  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1879  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1880  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1881  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1882  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1883  1876  3 10:25 pts/1    00:00:04 java_vm 
ian       1886  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1892  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1895  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1896  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1897  1854  0 10:25 pts/1    00:00:00 /usr/local/mozilla/mozilla-bin
ian       1898  1854  0 10:25 pts/1    00:00:00 /usr/local/mozilla/mozilla-bin
ian       1899  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1900  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1904  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1905  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1906  1876  4 10:25 pts/1    00:00:05 java_vm 
ian       1911  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1912  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1915  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1921  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1926  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1930  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1934  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1938  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1942  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1946  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1950  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1954  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1958  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1962  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1966  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1970  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1974  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1978  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1982  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1986  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1990  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       1994  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       2000  1876  0 10:25 pts/1    00:00:00 java_vm 
ian       2004  1876  0 10:26 pts/1    00:00:00 java_vm 
ian       2005  1876  0 10:26 pts/1    00:00:00 java_vm 
ian       2007  1876  0 10:26 pts/1    00:00:00 java_vm 
ian       2009  1876  0 10:26 pts/1    00:00:00 java_vm 
ian       2011  1876  0 10:26 pts/1    00:00:00 java_vm 
ian       2013  1876  0 10:26 pts/1    00:00:00 java_vm 
ian       2014  1876  0 10:26 pts/1    00:00:00 java_vm 
ian       2015  1876  0 10:26 pts/1    00:00:00 java_vm 
ian       2016  1876  0 10:26 pts/1    00:00:00 java_vm 
ian       2017  1876  0 10:26 pts/1    00:00:00 java_vm 

Adding URL and altering summary, orginal one was "Mozilla hangs when reloading
certain URLs"
Summary: Mozilla hangs when reloading certain URLs → linsoft.se - Java and Mozilla hang when loading certain URLs
(Reporter)

Comment 7

16 years ago
I'm also using RedHat 7.3 and Mozilla 2002083005, but uses "Java(TM) Plug-in
1.3.1_02-b02". If I counted right, I get 31 java_vm processes. However none of
these processes shows up when I use the top command, until I kill Mozilla, then
suddenly the java_vm gets real CPU hungry:

 1972 frank     25   0 26128  25M  9636 R    97,3  6,7   5:25 java_vm

Comment 8

16 years ago
Same here but that is just the result of mozilla and java hanging. Someone needs
to look at the java the site is using and see why it causes mozilla and java to
hang.
(Reporter)

Comment 9

16 years ago
I've made a very simple html page which only(almost) contains several reference
to the applet "addItem.class" used at the site. I downloaded the applet and put
it at a suitable directory and loaded the html page from disk. What seems to be
important is the number of instances of the applet. Perhaps there's some race
condition when several applet instances calls, for instance, the method
getParameter of the Applet class simultaneously. Since I only got a very low
level knowledge of Applet-programming, and also failed to decompile the class
file to a compileable java file I gave up (should be possible, using a better
decompile program though, or suitable modification of the generated source code).
(Reporter)

Comment 10

16 years ago
I made an uggly applet doing nothing more than getting parameters from the html
page. Looking like this:


import java.applet.Applet;
import java.awt.*;
public class addItem2 extends Applet
{
    public void init()
    {
        getParameter("caption");
        getParameter("description");
        getParameter("id");
        getParameter("price");
    }
}


and the html page looked like this:

<html>
<head>
<title>Test</title>
</head>
<body>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description1">
<param name="id" value="id1">
<param name="price" value="11">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description2">
<param name="id" value="id2>
<param name="price" value="22">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description3">
<param name="id" value="id3">
<param name="price" value="33">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description4">
<param name="id" value="id4">
<param name="price" value="44">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description5">
<param name="id" value="id5">
<param name="price" value="55">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description6">
<param name="id" value="id6>
<param name="price" value="66">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description7">
<param name="id" value="id7">
<param name="price" value="77">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description8">
<param name="id" value="id8">
<param name="price" value="88">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description9">
<param name="id" value="id9">
<param name="price" value="99">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description10">
<param name="id" value="id10>
<param name="price" value="1010">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description11">
<param name="id" value="id11">
<param name="price" value="1111">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description12">
<param name="id" value="id12">
<param name="price" value="1212">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description13">
<param name="id" value="id13">
<param name="price" value="1313">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description14">
<param name="id" value="id14">
<param name="price" value="1414">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description15">
<param name="id" value="id15">
<param name="price" value="1515">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description16">
<param name="id" value="id16">
<param name="price" value="1616">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description17">
<param name="id" value="id17>
<param name="price" value="1717">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description3">
<param name="id" value="id18">
<param name="price" value="1818">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description19">
<param name="id" value="id19">
<param name="price" value="1919">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description20">
<param name="id" value="id20">
<param name="price" value="2020">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description21">
<param name="id" value="id21>
<param name="price" value="2121">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description22">
<param name="id" value="id22">
<param name="price" value="2222">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description23">
<param name="id" value="id23">
<param name="price" value="2323">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description24">
<param name="id" value="id24">
<param name="price" value="2424">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description25">
<param name="id" value="id25>
<param name="price" value="2525">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description26">
<param name="id" value="id26">
<param name="price" value="2626">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description27">
<param name="id" value="id27">
<param name="price" value="2727">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description28">
<param name="id" value="id28">
<param name="price" value="2828">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description2">
<param name="id" value="id29>
<param name="price" value="2929">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description30">
<param name="id" value="id30">
<param name="price" value="3030">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description31">
<param name="id" value="id31">
<param name="price" value="3131">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description32">
<param name="id" value="id32">
<param name="price" value="3232">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description33">
<param name="id" value="id33>
<param name="price" value="3333">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description34">
<param name="id" value="id34">
<param name="price" value="3434">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description35">
<param name="id" value="id35">
<param name="price" value="3535">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description36">
<param name="id" value="id36">
<param name="price" value="3636">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description37">
<param name="id" value="id37>
<param name="price" value="3737">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description38">
<param name="id" value="id38">
<param name="price" value="3838">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description39">
<param name="id" value="id39">
<param name="price" value="3939">
</applet>
<applet CODEBASE="easyshop/" CODE="addItem2.class" HEIGHT="200" WIDTH="310"
align="right">
<param name="caption" value="Buy">
<param name="description" value="Description40">
<param name="id" value="id40>
<param name="price" value="4040">
</applet>
</body>
</html>

And I managed to get the same behavior as at linsoft.se. Well, perhaps I had to
push the reload button one extra time.

I'm afraid I can't help you Mozilla people more than this (if this was any
help). Keep the good work up!! Bye!
(Assignee)

Comment 11

16 years ago
It seemed working for me with mozilla 1.0 and JRE 1.4.1. 
Reporter, try download JRE 1.4.1rc from java.sun.com/j2se, and rerun the test
case. See what happens.
(Reporter)

Comment 12

16 years ago
Yes, it works, and I'm running "Java(TM) Plug-in 1.4.1-rc-b19" and Mozilla build
2002090504. I don't want to be ungrateful but isn't it awful slow? I've tried
Mozilla on Windows2k using Java plug-in 1.4.0_01 and Mozilla 20020906 and the
page seems to be loaded and running about three times faster. Is there some
changes in the instanciation of the child JVM's of the java plug-in 1.4.1? More
serialized in some way? Just a bit curious :-)
(Reporter)

Comment 13

16 years ago
The test I made when complaining the Linux setup was slow, was running the page
with the URL: http://www.linsoft.se/butiken/prisl/borland.htm
However, running the test.html (from "Additional Comment #10") later showed me
that it was the Windows setup that was real slow instead (when I used the Java
plug-in 1.4.0_01). I got very confused about that, so I made some unscientific
tests:

Linux setup (RH 7.3, Mozilla 2002090505,"Java(TM) Plug-in 1.4.1-rc-b19") :
Loading test.html: 5 sec
Loading linsoft.se: 12 sec

Windows setup #1 (Win2k, Mozilla 20020906, Java plug-in 1.4.0_01) :
Loading test.html: 70 sec (what did I do wrong)
Loading linsoft.se: 4 sec (sometimes slower)

Windows setup #2 (Win2k, Mozilla 20020906, Java plug-in 1.4.1) :
Loading test.html: 1 sec (that's better :-))
Loading linsoft.se: 3 sec (I don't complain)

The only thing this suggest to me, is that I shouldn't complain about the speed
in Java 1.4.1.
(Assignee)

Comment 14

16 years ago
Thanks for the testing infomation, Frank.
Marking WFM.


(Assignee)

Comment 15

16 years ago
One more thing for the page loading time: if it is the first time that you load
a java page, then it will take longer time to load the page, since the JVM needs
to be started first.
(Assignee)

Comment 16

16 years ago
Marking WFM.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 17

16 years ago
Well, thanks. I'm just trying to help :-)
However, it bothers me that the Linux version is so slow loading the linsoft.se
page. The times that are given (additional comment #13) are the time it takes to
reload the pages (forgot to mention that). I can't figure out the reason why the
Linux setup is so slow. Is it the Linux version of the jvm that are much slower
in some way, or is it the Mozilla code in the Linux version that should be
modified to speed things up? I'm just a bit curious, again :-)

Comment 18

16 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: joe.chou → petersen
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.