Closed Bug 1659074 Opened 1 month ago Closed 1 month ago

Land unit tests of sendMessage/onMessage of uncloneable responses

Categories

(WebExtensions :: General, task)

task

Tracking

(firefox81 fixed)

RESOLVED FIXED
81 Branch
Tracking Status
firefox81 --- fixed

People

(Reporter: robwu, Assigned: robwu)

References

Details

Attachments

(1 file)

In bug 1655624 I added unit tests that were unrelated to the original bug report. The test cannot land, because there is a debug-only crash (bug 1658827).

I'll move the test over to this bug and mark it as blocked on bug 1658827 (or disable part of it on debug builds) so that we don't forget about it.

Bug 1658827 got fixed thanks to Nika, I'm going to land the patch.

Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/5d6808bba6af
Regression tests for undefined/uncloneable error in onMessage r=zombie,geckoview-reviewers,agi
Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
You need to log in before you can comment on or make changes to this bug.