Closed Bug 1659421 Opened 1 year ago Closed 1 year ago

htmlreference.io webpage is displayed as cut off in both print preview and actual print output

Categories

(Core :: Print Preview, defect)

Firefox 81
defect

Tracking

()

RESOLVED DUPLICATE of bug 1414600
Tracking Status
firefox81 --- affected

People

(Reporter: emilghitta, Unassigned)

References

(Blocks 2 open bugs, )

Details

(Whiteboard: [print2020_v81])

Attachments

(3 files)

Attached image printPreview.gif

Affected versions

  • 81.0a1 (BuildId:20200816214203)

Affected platforms

  • Windows 10 64bit
  • macOS 10.14

Unaffected Platforms

  • Ubuntu 18.04 64bit.

Preconditions

  • Ensure that the print.tab_modal.enabled pref is set to true

Steps to reproduce

  1. Launch Firefox.
  2. Access the following page
  3. Open print preview.
  4. Print the file (via pdf or actual paper).

Expected result

  • The page is successfully displayed & printed.

Actual result

  • The page is displayed as cut off in both print preview & in the actual print output (both print to file & print to paper).

Regression Window

  • This seems to be reproducible with print.tab_modal.enabled pref set to true (switching it to false successfully displays the page in print to file, print to paper & inside print preview.

Additional Information

  • For further information regarding this issue in print preview observe the attached screencast.
  • I will be attaching the output for print to file and paper for both Firefox, Chrome and Firefox uit pref off shortly.
  • [Suggested Severity] : S2
Attached file printToFile.7z
Attached image printToFile.jpg

This feels more like a Core::Print Preview bug to me…

Component: Printing → Print Preview
Product: Toolkit → Core
Whiteboard: [print2020_v81]

I get the same print output with and without the new print UI. I think this is bug 1414600 (which makes a media query in the site match that shows the sidebar and messes up the design).

(In reply to Emilio Cobos Álvarez (:emilio) from comment #4)

I get the same print output with and without the new print UI. I think this is bug 1414600 (which makes a media query in the site match that shows the sidebar and messes up the design).

Curious. From comment 0 that doesn't seem to be the behaviour Emil is seeing:

(In reply to Emil Ghitta, QA [:emilghitta] from comment #0)

  • This seems to be reproducible with print.tab_modal.enabled pref set to true (switching it to false successfully displays the page in print to file, print to paper & inside print preview.

I confirmed that the patch in bug 1414600 fixes this.

I can't repro this:

This seems to be reproducible with print.tab_modal.enabled pref set to true (switching it to false successfully displays the page in print to file, print to paper & inside print preview.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1414600
You need to log in before you can comment on or make changes to this bug.