Closed Bug 1659497 Opened 1 year ago Closed 1 year ago

About pages cannot be printed

Categories

(Toolkit :: Printing, defect)

Firefox 81
All
Linux
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox81 --- affected

People

(Reporter: Anca, Unassigned)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [print2020_v81])

Affected versions

  • 81.0a1

Affected platforms

  • Ubuntu 18.04

Steps to reproduce

  1. Launch Firefox
  2. Make sure the print UI via print.tab_modal.enabled is set on true
  3. Open about:support
  4. Hit CTRL + P
  5. Print to paper

Expected result

  • The about:support content is printed

Actual result

  • The Printing loading dialog is displayed for a moment, then nothing happens, no actually printing is done

Regression range

  • Not able to print this page since print.tab_modal.enabled pref was enabled (7th August)

Additional notes

  • The only error I see inside the console is Uncaught (in promise) undefined
  • I am only managing to print the page from Print using the system dialog…
  • I can print about:home, I can't print about:networking or about:config

Suggested severity

  • I think that S2 is suitable for this issue

Does this not affect Windows/macOS? Does this affect all your Linux machines?

Flags: needinfo?(anca.soncutean)
See Also: → 1659470

Seems fine for me on MacOS…

(In reply to :Gijs (he/him) from comment #1)

Does this not affect Windows/macOS? Does this affect all your Linux machines?

This was submitted as Linux only, but doubled checked today with eghitta on his Ubuntu 18.04, about pages are printed without any issue on his end. I will not have access in the near future to that specific printer on which I’ve reproduced the issue; as a side note, when submitting it, the win/mac confirmation for not reproducing this problem, was done with other printers; I don't know what could cause the issue to reproduce exclusively with that setting, on older Nightly builds the about pages were printed; I will look more into this as soon as I‘ll have access again.

Flags: needinfo?(anca.soncutean)

None of the developers seem able to duplicate this, so I'm going to mark it was WFM, but if it crops up again, please re-open, and we can try to dig in a little more…

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.