Closed Bug 1659845 Opened 1 month ago Closed 1 month ago

Implements Khmer line-breaking support on Android

Categories

(Core :: Internationalization, defect)

79 Branch
Unspecified
Android
defect

Tracking

()

RESOLVED DUPLICATE of bug 1553725
Webcompat Priority ?
Tracking Status
firefox79 --- affected
firefox80 --- affected
firefox81 --- affected

People

(Reporter: karlcow, Unassigned)

References

()

Details

  1. With Firefox Android
  2. Go to https://privacy.google.com/?hl=km#overview

Expected:
Lines are wrapping

Actual:
Lines overflow the content

Probably related to Bug 771753 (Windows) or duplicate?
The wrapping is working on Firefox macOS but not on Firefox Android.
The wrapping is working on Chrome Android.

kato-san,
If it's a simple change I'm happy to provide a patch with a bit of help.

Flags: needinfo?(m_kato)

(In reply to Karl Dubost💡 :karlcow from comment #2)

kato-san,
If it's a simple change I'm happy to provide a patch with a bit of help.

Old Android doesn't have native line break API, but Android 24+ can use ICU from Java (android.icu.text.BreakIterator). Since we still support Android 5+ on Fenix, so not easy.

Flags: needinfo?(m_kato)
Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1553725
You need to log in before you can comment on or make changes to this bug.