Closed Bug 1660260 Opened 3 months ago Closed 3 months ago

In event/todo summaries the description field shows HTML tags

Categories

(Calendar :: Dialogs, enhancement, P2)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1659363

People

(Reporter: pmorris, Assigned: pmorris)

References

Details

As in bug 1659363, Google calendar puts HTML tags in the DESCRIPTION of calendar events for formatting (bold, italic, etc.). This doesn't exactly follow the iCalendar spec where DESCRIPTION is plain text.

So for readability, when we are displaying descriptions in read-only contexts, we should strip out the HTML tags and just show the text content. Bug 1659363 took care of invitations in emails; this bug is for the event/todo summary dialog and ICS file import dialog.

(In the edit event dialog where the description is editable we should show the actual raw contents of the description property, i.e. include the HTML tags.)

Closing this since I'm handling it as part of bug 1659363.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1659363
You need to log in before you can comment on or make changes to this bug.