Closed Bug 1660264 Opened 5 months ago Closed 5 months ago

WebCompat Reporter add-on no longer functional

Categories

(Web Compatibility :: Tooling & Investigations, defect, P1)

Unspecified
All

Tracking

(firefox-esr68 unaffected, firefox-esr78 unaffected, firefox79 unaffected, firefox80 unaffected, firefox81+ fixed)

RESOLVED FIXED
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox79 --- unaffected
firefox80 --- unaffected
firefox81 + fixed

People

(Reporter: csadilek, Assigned: twisniewski)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Report in Fenix of a recent regression affecting the Webcompat Reporter add-on e.g. the browser action ("Report site issue") doesn't work anymore.

We're seeing the following the logs:

[Exception... "File error: Not found"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/Troubleshoot.jsm :: <TOP_LEVEL> :: line 25"  data: no] 6 Troubleshoot.jsm:25:34
    <anonymous> resource://gre/modules/Troubleshoot.jsm:25
    <anonymous> jar:file:///data/app/org.mozilla.fenix-klil-iVhoNAtsPc3fVO4cg==/base.apk!/assets/extensions/webcompat-reporter/experimentalAPIs/browserInfo.js:12
    asyncLoaded resource://gre/modules/ExtensionCommon.jsm:1664

Looks like this is a regression from Bug 1361712. Subprocess is not available on mobile.

:jaws can you take a look?

Component: Extensions → Mobile
Flags: needinfo?(jaws)
Product: GeckoView → Web Compatibility
Regressed by: 1361712
Component: Mobile → Tooling & Investigations
Severity: -- → S1
Keywords: regression

Depending on the complexity of the fix, we could just disable the webrender detection on mobile?

Assignee: nobody → twisniewski
Priority: -- → P1

Yes, it looks like we can fix this with https://github.com/mozilla-mobile/android-components/pull/8173

But I'll also remove the same code from the version of the addon in m-c, since we don't need it on desktop either. Patch incoming.

Flags: needinfo?(jaws)
Pushed by twisniewski@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/308e4353d2c9
remove code we no longer need from the report site issue extension; r=denschub,webcompat-reviewers
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.