Closed Bug 1660290 Opened 8 months ago Closed 8 months ago

AXPreviousTextMarkerForTextMarker does not work consistently

Categories

(Core :: Disability Access APIs, defect, P1)

All
macOS
defect

Tracking

()

RESOLVED FIXED
82 Branch
Tracking Status
firefox82 --- fixed

People

(Reporter: eeejay, Assigned: eeejay)

References

Details

(Whiteboard: [mac2020_2])

Attachments

(1 file)

Iterating backwards, linked list style, using AXPreviousTextMarkerForTextMarker. Gives inconsistent results with forward iterating with AXNextTextMarkerForTextMarker. This is mostly caused by the way we normalize the offset to point to the first character in the deepest hyperlink, or the end offset outside of a link if it was on the last character there.

This causes us to skip hyperlink elements when iterating backwards.

Assignee: nobody → eitan
Priority: P2 → P1
Whiteboard: [mac2020_1] → [mac2020_2]
Blocks: 1660303
Pushed by eisaacson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/486321748d93
Robustify text marker reverse iteration. r=Jamie
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch
You need to log in before you can comment on or make changes to this bug.