Crash in gkcontent.dll when pressing ctrl-tab after zapping (deleting) IFRAME [@ nsEventStateManager::IsIFrameDoc]

VERIFIED DUPLICATE of bug 146255

Status

()

Core
DOM: Events
--
critical
VERIFIED DUPLICATE of bug 146255
15 years ago
15 years ago

People

(Reporter: Lorenzo Colitti, Assigned: joki (gone))

Tracking

({crash, regression, testcase})

Trunk
x86
Windows ME
crash, regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Talkback ID 10194420Q, crash signature, URL)

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.1) Gecko/20020826

If you use Jesse Ruderman's "Zap Embeds" bookmarklet:

http://www.squarefree.com/bookmarklets/zap.html

on a page with IFRAMEs, and then press CTRL-TAB, Mozilla crashes.

Reproducible: Always

Steps to Reproduce:
1. Go to URL.
2. Use Zap embeds bookmarklet, which deletes IFRAMEs.
3. Press CTRL-TAB.
Actual Results:  
Crash in gkcontent.dll.

Expected Results:  
No crash, URL bar is highlighted.

Talkback ID 10194420Q

This may be related to bug 146255. I'm submitting it as a separate bug because
the stacks may be different.

The Zap Embeds bookmark, by the way, is this:

javascript:(function(){var d=document; function K(N,t) { var b =
d.createElement("div"); b.style.width=N.width; b.style.height=N.height;
b.innerHTML="<del>" + t + "</del>"; N.parentNode.replaceChild(b,N); } function
Z(t) { var T = d.getElementsByTagName(t), i; for (i=T.length-1;i+1;--i)
K(T[i],t); } Z("object"); Z("embed"); Z("applet"); Z("iframe");})();
(Reporter)

Updated

15 years ago
Keywords: crash, stackwanted
Whiteboard: Talkback ID 10194420Q
(Reporter)

Comment 1

15 years ago
This does not happen in 1.0.1 RC2. Adding regression keyword.
Keywords: regression
(Reporter)

Comment 2

15 years ago
Created attachment 97450 [details]
HTML file for IFRAME content
(Reporter)

Comment 3

15 years ago
Created attachment 97451 [details]
testcase

testcase. Requires attachment 97450 [details]. Instructions included.

Comment 4

15 years ago
Created attachment 97453 [details]
Stack with Linux build 20020901 (trunk)

Comment 5

15 years ago
same stack as bug 146255.

*** This bug has been marked as a duplicate of 146255 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Keywords: stackwanted → testcase
Resolution: --- → DUPLICATE
Summary: Crash in gkcontent.dll when pressing ctrl-tab after zapping (deleting) IFRAME → Crash in gkcontent.dll when pressing ctrl-tab after zapping (deleting) IFRAME [@ nsEventStateManager::IsIFrameDoc]

Comment 6

15 years ago
verifying
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsEventStateManager::IsIFrameDoc]
You need to log in before you can comment on or make changes to this bug.