Closed Bug 166040 Opened 18 years ago Closed 17 years ago

Mozilla loops indefinetly with bad HTML

Categories

(Core :: DOM: Navigation, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 170021

People

(Reporter: Mitch, Assigned: asa)

References

()

Details

The URL mentioned, http://www.waitrose.co.uk loops mozilla
cvs 20020901 indefinetly when there is a bad HTML META tag.

The URL given servers up this content...

  <html>
  <head>
  <meta http-equiv="refresh" content="0 URL=http://www.waitrose.com">
  </head>
  <body>
  .
  </body>

Notice, no semicolon between the "0" and "URL". 

Mozilla should barf instead of looping forever.

Maybe a job for  evangelism (doesn't appear to be a category for logging
bugs for evangelism) ?
In this case, Mozilla is performing the instructions on the page perfectly. At
the same time, it doesn't prevent the user from pressing "Stop" or closing the
window/tab, so there's no problem with Mozilla here. The only problem is with
the code of the page.
Also, there is a separate "Product" for evangelism problems.
No, it's really a bug. The redirect goes to www.waitrose.com, not to the same
page (www.waitrose.co.uk). Mozilla always reloads the same page, possible due to
the missing semicolon.
We really need to work on not aassuming that "malformed uri" means "" in cases
like this....
Is anyone working on this ?
WorksForMe, Moz 1.3b on WinXP.

I'm going ahead and marking this as a duplicate of bug 170021, I'm assuming that
rewrite of the meta refresh code took care of this (see testcase 1 of that bug).

*** This bug has been marked as a duplicate of 170021 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Component: Browser-General → Embedding: Docshell
QA Contact: asa → adamlock
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.