Closed Bug 1660492 Opened 1 year ago Closed 1 year ago

When Print Selection, It needs extra steps. The New preview is totally useless in this case and users will be confused..

Categories

(Toolkit :: Printing, defect, P3)

Desktop
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 140718
Tracking Status
firefox81 --- affected

People

(Reporter: alice0775, Unassigned)

Details

(Keywords: ux-discovery, ux-userfeedback)

STR

Old way:

  1. Select some page content
  2. Alt > File > Print... >
  3. Check "Selection" in Page Range > Print

New Print Dialog:

  1. Select some page content
  2. Alt > File > Print... >
    --- In this time, the preview shown is completely useless.
  3. Print using the system dialog >
  4. Check "Selection" in Page Range > Print >
  5. Click on [Cancel] button

Actual Results:
It needs extra steps.
The New preview is totally useless in this case. Users will be confused.

Expected Results:
Interaction with users should be simplified as much as possible.
Such a confusing UI should be avoided.

Suggestion:
The "Selection" option should be provided in the New Print Preview itself.
If the "Selection" option is chosen, the preview should be redrawn according to the printing range.

OR
Leave the menu File > Print so that system dialog will popup

Keywords: ux-userfeedback

Print selection is out of scope for 81, but maybe there's something we want do to do indicate that…

Severity: -- → S2
Priority: -- → P3
Whiteboard: [print2020_v82]

[Moving front-end printing v82 bugs to v83.]

Whiteboard: [print2020_v82] → [print2020_v83]

I don't think we need this separate from bug 140718. I've just retitled that bug.

No longer blocks: 133787
Status: NEW → RESOLVED
Closed: 1 year ago
No longer depends on: 140718
Resolution: --- → DUPLICATE
Whiteboard: [print2020_v83]
Duplicate of bug: 140718
You need to log in before you can comment on or make changes to this bug.