Open Bug 1660667 Opened 1 year ago Updated 1 year ago

Visual corruption with WR in logged in old reddit

Categories

(Core :: Graphics: WebRender, defect)

defect

Tracking

()

REOPENED
Tracking Status
firefox81 --- affected

People

(Reporter: yoasif, Unassigned, NeedInfo)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached file about:support

Hmm, I could not reproduce the problem with my Win10 PCs.
Asif Youssuff, can you reproduce the problem with other Win10 PC?

Flags: needinfo?(yoasif)

Sotaro, I don't use any other Windows PC with enough regularity to try to reproduce the issue.

Flags: needinfo?(yoasif)

:gw, do you have any ideas about a cause of the problem?

Flags: needinfo?(gwatson)

I also can't repro locally on my Win10/Intel machine. Does it still occur if DirectComposition is disabled in about:config?

Flags: needinfo?(gwatson)

What is the preference for DirectComposition in about:config?

(In reply to Asif Youssuff from comment #6)

What is the preference for DirectComposition in about:config?

Setting gfx.webrender.compositor to be false and restarting should do it, I think.

Flags: needinfo?(yoasif)

@Asif: Could you also try updating the intel graphics driver?

Severity: -- → S3

I haven't seen the issue in the days since disabling DirectComposition.

I'm pretty sure I was running the latest version of the driver provided by Windows Update - I have now downloaded a newer version via Intel's website.

I went ahead and re-enabled DirectComposition since updating the driver this morning.

Flags: needinfo?(yoasif)

Asif, did the new driver version solve the problem with DirectComposition enabled? Thanks!

Flags: needinfo?(yoasif)

Andrew, I honestly stopped running Windows on that machine due to the awful performance on it - and it didn't happen all the time, so I'd probably have to run it for a somewhat extended period of time. I'll go ahead and do that now since I have another needinfo for that same hardware.

(In reply to Andrew Osmond [:aosmond] from comment #10)

Asif, did the new driver version solve the problem with DirectComposition enabled? Thanks!

It looks like the new driver version fixed the issue.

Flags: needinfo?(yoasif)
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME

Kris, isn't this still a bug with the driver version I initially reported the bug with?

Flags: needinfo?(ktaeleman)

@andrew: Asif has a point, should we block the driver version?

Status: RESOLVED → REOPENED
Flags: needinfo?(ktaeleman) → needinfo?(aosmond)
Resolution: WORKSFORME → ---
No longer blocks: gfx-triage
You need to log in before you can comment on or make changes to this bug.