Closed Bug 1660720 Opened 1 year ago Closed 1 year ago

Printing is blocked forever so long as the last used printer is offline/disconnected

Categories

(Toolkit :: Printing, defect, P1)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jwatt, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [print2020_v81])

If the last used printer is offline, the preview spinner spins forever. Since I then can't print to update the last used printer, I'm stuck. (Well, I happen to know how to edit prefs, but 99.999% of people will not figure out how to unblock printing.)

I was sure Emily filed a bug to expose whether a printer is online but I can't find it right now. Emily?

Regardless, it seems like the frontend code should abort the current print preview operation when the user chooses another printer from the dropdown, and set up a new print preview with the settings for that printer.

Flags: needinfo?(emcdonough)

I have linked the bugs.

No longer depends on: 1660905
Flags: needinfo?(emcdonough)
Depends on: 1660905

Hi Emil: This is one of our concerns as far as open P1s for the new print UI. Would you be able to check this as part of your next test run?

Flags: needinfo?(emil.ghitta)

I can't repro now. As mentioned on the group call earlier, I think this may have been a symptom of an error that was occurring in the frontend code that has since been fixed. I just talked to Emil and QA doesn't seem to be abe to reproduce this either. I'll leave the needinfo here so Emil can comment, but I'll close the bug.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
No longer depends on: 1660905

(In reply to Sean Voisen (:svoisen) from comment #2)

Hi Emil: This is one of our concerns as far as open P1s for the new print UI. Would you be able to check this as part of your next test run?

Sure thing. I've added a new test case that covers this scenario and we will make sure to include this as well in our test run.

As Jonathan mentioned in Comment 3, we are not able to reproduce this issue but we will get back if this is encountered during our tests.

Flags: needinfo?(emil.ghitta) → in-qa-testsuite+
You need to log in before you can comment on or make changes to this bug.