Closed Bug 1660875 Opened 1 year ago Closed 1 year ago

Text is fuzzy and unselectable, after printing to PDF with "Color mode: Black and white"

Categories

(Core :: Print Preview, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1660857

People

(Reporter: dholbert, Unassigned)

References

Details

(Whiteboard: [print2020_v81])

Attachments

(3 files)

Attached file testcase 1

STR:

  1. Ensure you have print.tab_modal.enabled = true in about:config
  2. View attached testcase.
  3. Print with Ctrl+P
  4. In the "Color mode" dropdown, choose "Black & White"
  5. Choose "Save to PDF" as your printer, and click "Save" at the bottom.
  6. Open the resulting PDF, and try to select text in your PDF viewer. Try Ctrl+F "find" (or equivalent in your PDF viewer), to find some of the text.

ACTUAL RESULTS:
The text is blurry and un-selectable, and the "find" feature does not work. It seems the test has been rasterized to a (blurry) graphical result, and the PDF doesn't realize that it's got text in it.

EXPECTED RESULTS:
Selectable/findable text in the resulting PDF (ideally not blurry).

Keywords: 64bit
Whiteboard: [print2020]
Flags: needinfo?(emilio)

(Note: the gray border around the page content is also unexpected, and it's tracked in related bug 1660857.)

See Also: → 1631449
See Also: 16314491660857

Looks like this may actually be fixed by a patch on bug 1660857. Duping for now, though we can un-dupe later if needed.

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(emilio)
Resolution: --- → DUPLICATE
See Also: 1660857
Duplicate of bug: 1660857
Keywords: 64bit
Whiteboard: [print2020] → [print2020_v81]
You need to log in before you can comment on or make changes to this bug.