Closed Bug 1661048 Opened 1 year ago Closed 1 year ago

Prevent typing non-numeric characters into numeric fields

Categories

(Toolkit :: Printing, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1660060

People

(Reporter: mstriemer, Unassigned)

References

(Blocks 1 open bug)

Details

You can type non-numeric or invalid characters into the numeric fields (copies, page range, scale). These will always cause the field to be invalid so we should prevent it instead.

Whiteboard: [print2020_v81]

In the case of Scale, entering a decimal (e.g. 33.333%) might seem reasonable enough, although if I try, it complains "Scale must be a number between 10 and 200."

Floating point conversion unfortunately makes entering decimal values into the scale field unwieldy. If we allow decimals then entering 14 would result in 14.000000000000002 being entered into the field on the next print load.

Looks like bug 1660060 was already on file for the non-numeric stuff.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Whiteboard: [print2020_v81]
Duplicate of bug: 1660060
You need to log in before you can comment on or make changes to this bug.