Closed Bug 1661451 Opened 1 year ago Closed 1 year ago

Crash in [@ h_ixsvzagv.dll | RtlPcToFileHeader | CxxThrowException | _com_raise_error]

Categories

(Core :: Print Preview, defect, P3)

Firefox 82
All
Windows 10
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: Anca, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: crash, regression, Whiteboard: [print2020_v81] [old-ui-])

Crash Data

Attachments

(1 file)

Attached image screencast issue .gif

Crash report: https://crash-stats.mozilla.org/report/index/419fb36a-db56-4138-acdf-61b590200827

Top 10 frames of crashing thread:

0 h_ixsvzagv.dll h_ixsvzagv.dll@0x23e49 
1 h_ixsvzagv.dll h_ixsvzagv.dll@0x23e48 
2 ntdll.dll RtlPcToFileHeader 
3 vbufbackend_gecko_ia2.dll CxxThrowException f:\dd\vctools\crt\vcruntime\src\eh\throw.cpp:129
4 vbufbackend_gecko_ia2.dll _com_raise_error f:\dd\vctools\compiler\cxxfe\sl\vccom\comraise.cpp:18
5 vbufbackend_gecko_ia2.dll _com_ptr_t<_com_IIID<IAccessible2, &_GUID const IID_IAccessible2> >::_com_ptr_t<_com_IIID<IAccessible2, &_GUID const IID_IAccessible2> ><_com_IIID<IAccessibleHyperlink, &_GUID const IID_IAccessibleHyperlink> > c:\program files (x86)\microsoft visual studio\2017\community\vc\tools\msvc\14.15.26726\include\comip.h:86
6 vbufbackend_gecko_ia2.dll GeckoVBufBackend_t::fillVBuf c:\projects\nvda\build\x86_64\vbufbackends\gecko_ia2\gecko_ia2.cpp:827
7 vbufbackend_gecko_ia2.dll GeckoVBufBackend_t::fillVBuf c:\projects\nvda\build\x86_64\vbufbackends\gecko_ia2\gecko_ia2.cpp:831
8 vbufbackend_gecko_ia2.dll GeckoVBufBackend_t::fillVBuf c:\projects\nvda\build\x86_64\vbufbackends\gecko_ia2\gecko_ia2.cpp:831
9 vbufbackend_gecko_ia2.dll GeckoVBufBackend_t::fillVBuf c:\projects\nvda\build\x86_64\vbufbackends\gecko_ia2\gecko_ia2.cpp:831

Affected versions

  • 82.0a1

Affected platforms

  • Windows 10

Affected platforms

  • macOS 10.14
  • Ubuntu 20.04

Steps to reproduce

  1. Launch Firefox
  2. Make sure print.tab_modal.enabled is set on true
  3. Open several tabs
  4. Run window.print() inside the web console, while having in focus any of the tab
  5. After a while close any other tab (not the one in focus) - If not waited enough, I crash the browser only with the second close attempt on the same tab (see screenshot)

Regression range

Suggested severity

  • S3

Crashes with .cpp in the stacks are usually platform bugs, but I have no idea what part of the printing system this might be! o_O

Component: Printing → Print Preview
Product: Toolkit → Core

Looks like this might be accessibility related, I see NVDA DLLs in the stacks.

Flags: needinfo?(jteh)
Severity: -- → S2
Priority: -- → P1

I tried to reproduce the crash locally on my Windows laptop, but can't. (Thanks to Morgan to make me notice that I need to install NVDA first).

Also Jamie told me on Matrix that h_ixsvzagv.dll looks like antivirus things. In google search there is no result about the dll, in DDG, there are some but looks unrelated.

Jamie, how would we detect that NVDA (or any a11y agent?) is being used? If it comes down to it maybe the pragmatic thing to do for v81 is to disable the new printing UI in that case to give us more time to investigate? (Although we only have one crash report so far.)

I don't know what h_ixsvzagv.dll is. The fact that I can't find any details about it anywhere is very suspicious and we should potentially consider blocking it. That said:

This crash is being caused by NVDA. This is an old, now unsupported version of NVDA (2018.3) and this bug has already been fixed in later versions (2019.1 and above).

I don't think we need to do anything here. Anyone encountering this in real usage is running an old, unsupported version of NVDA, and given that NVDA is free, there's really no excuse not to upgrade.

:Anca, it'd be good to ensure all Softvision testers are running an up-to-date version of NVDA for testing.

Flags: needinfo?(jteh) → needinfo?(anca.soncutean)

Thanks, Jamie. Based on that and on the fact that there's only been a single crash with this signature, I'm going to drop this down to P3. Once Anca has updated NVDA and retested we can close this if the crash no longer reproduces.

Priority: P1 → P3
Has STR: --- → yes

(In reply to Jonathan Watt [:jwatt] from comment #6)

Thanks, Jamie. Based on that and on the fact that there's only been a single crash with this signature, I'm going to drop this down to P3. Once Anca has updated NVDA and retested we can close this if the crash no longer reproduces.

Yes, you are right, the NVDA version was an oversight from my side (also I’ve made sure, my colleagues received your message). I can no longer reproduce the crash after updating NVDA to the latest version on Nightly 82.0a1 (2020-08-31). I'll mark this crash accordingly.

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(anca.soncutean)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.