Closed Bug 1661517 Opened 2 years ago Closed 2 years ago

Remove extensions.allowPrivateBrowsingByDefault preference

Categories

(WebExtensions :: General, task, P3)

task

Tracking

(firefox91 verified)

VERIFIED FIXED
91 Branch
Tracking Status
firefox91 --- verified

People

(Reporter: mixedpuppy, Assigned: soniasingla, Mentored)

References

(Blocks 1 open bug)

Details

(Keywords: good-first-bug)

Attachments

(2 files)

No description provided.

is this issue still open? if yes, can I attempt it, please?
charlesanita403@gmail.com

Flags: needinfo?(mixedpuppy)

Thanks for your interest in this bug. I've clarified the title, Shane will follow up with a comment.

Mentor: mixedpuppy
Keywords: good-first-bug
Summary: remove feature pref for incognito → Remove extensions.allowPrivateBrowsingByDefault preference

I apologize for missing the question. Are you still interested in taking this?

Flags: needinfo?(charlesanita403)

No response, clearing need info's.

Flags: needinfo?(mixedpuppy)
Flags: needinfo?(charlesanita403)
Assignee: nobody → soniasingla.1812
Status: NEW → ASSIGNED
Blocks: 1678841
Blocks: 1678847

extensions.allowPrivateBrowsingByDefault is true by default in Tor Browser, differing from Firefox.

Issue in Tor Browser's GitLab

The Tor Browser uses permanent private browsing mode by default (via pref("browser.privatebrowsing.autostart", true);). We could look into automatically enabling extensions in permanent private browsing mode (bug 1585431). That work does not need to block this bug, since Tor builds on ESR anyway.

See Also: → 1460738, 1585431

Hey Sonia, just wanted to check in. :) Are you still working on this bug?

Hey Sonia, just another friendly check in on this issue. :) How's it going?

Updating it now, thanks for checking :)

This good-first-bug hasn't had any activity for 2 months, it is automatically unassigned.
For more information, please visit auto_nag documentation.

Assignee: soniasingla.1812 → nobody
Status: ASSIGNED → NEW
Assignee: nobody → soniasingla.1812
Status: NEW → ASSIGNED
Pushed by scaraveo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f2dbafe38826
Removed extensions.allowPrivateBrowsingByDefault preference. r=mixedpuppy
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch

Hello,

Verified the fix on the latest Nightly (91.0a1/20210603094827) under Windows x64 and Ubuntu 16.04 LTS.

Compared the existence of the pref in about:config between Nightly and Release. On Release the pref still exists and is set to false, while on Nightly it is no longer available, confirming the fix. For further details, please see the attached screenshot.

Status: RESOLVED → VERIFIED
Attached image 2021-06-04_12h44_46.png

Hi,

by removing this preference there is no more way to programmatically turn on this setting in testing environment with WebDriver.

I have web extension that talks with my app over WebDriver and controls proxy in browser. It is broken currently as extension cant call browser.proxy.settings.set api without private browsing permission and I have no way to set that permission from geckodriver.

(In reply to Boris Prpic from comment #18)

Hi,

by removing this preference there is no more way to programmatically turn on this setting in testing environment with WebDriver.

I have web extension that talks with my app over WebDriver and controls proxy in browser. It is broken currently as extension cant call browser.proxy.settings.set api without private browsing permission and I have no way to set that permission from geckodriver.

Could you file a new bug for this issue? Please include relevant information, such as a set of (minimal) steps to reproduce the issue.

(In reply to Rob Wu [:robwu] from comment #19)

(In reply to Boris Prpic from comment #18)

Hi,

by removing this preference there is no more way to programmatically turn on this setting in testing environment with WebDriver.

I have web extension that talks with my app over WebDriver and controls proxy in browser. It is broken currently as extension cant call browser.proxy.settings.set api without private browsing permission and I have no way to set that permission from geckodriver.

Could you file a new bug for this issue? Please include relevant information, such as a set of (minimal) steps to reproduce the issue.

OK. Here: https://bugzilla.mozilla.org/show_bug.cgi?id=1729315

See Also: → 1729315
You need to log in before you can comment on or make changes to this bug.