Closed Bug 1661608 Opened 3 months ago Closed 3 months ago

Assertion failure: aViewportType != ViewportType::Visual, at layout/generic/nsIFrame.cpp:6765

Categories

(Core :: Print Preview, defect)

defect

Tracking

()

RESOLVED FIXED
82 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- wontfix
firefox79 --- wontfix
firefox80 --- wontfix
firefox81 --- wontfix
firefox82 --- fixed

People

(Reporter: hiro, Assigned: botond)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [print2020_v81] [old-ui+] )

Attachments

(2 files)

STR;

  1. Open https://www.w3schools.com/html/html_iframe.asp
  2. Open the print preview window
  3. Click somewhere inside the iframe in the print preview

I am a bit worried that it's a result of bug 1660490. I wanted to do mozregression but mozregression doesn't work for debug builds now (bug 1661607).

Whiteboard: [print2020_v81] [old-ui+]

(In reply to Hiroyuki Ikezoe (:hiro) from comment #0)

I am a bit worried that it's a result of bug 1660490.

No, it's not! I did revert the change locally, but still I can get the assertion. (I need mozregresion..)

Attached file A call stack

I hadn't yet. :)

Assignee: nobody → botond
Regressed by: 1556556

Sorry, I may have misunderstood. I marked bug 1556556 as the regressing change because it is what introduced the assertion, but it sounds like this broke recently as a result of another change?

Mozregression points to the actual regressing bug being bug 1640381.

Regressed by: 1640381
No longer regressed by: 1556556
Pushed by bballo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/11a7c8990f93
Use correct viewport type in RecordMouseLocation(). r=tnikkel
Status: NEW → ASSIGNED
See Also: → 1661873
Severity: -- → S3
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch

Do we care to uplift this to Beta? It seems the regressing bug landed for v78 so I guess not, but asking just in case.

Flags: needinfo?(botond)

It's a debug-only assertion and I'm not expecting hitting this codepath to cause any trouble in terms of functionality, so let's not uplift.

Flags: needinfo?(botond)
Flags: needinfo?(jwatt)
Flags: needinfo?(jwatt)
You need to log in before you can comment on or make changes to this bug.