Closed Bug 1661666 Opened 11 months ago Closed 11 months ago

Loading indicator is an hourglass

Categories

(Firefox :: Theme, defect)

80 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1650028

People

(Reporter: martijn, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:80.0) Gecko/20100101 Firefox/80.0

Steps to reproduce:

Upgraded to Firefox 80, and the loading indicator on tabs is now an hourglass. This one feels like it's not loading. The animation indicates something is going, which is far better.

Actual results:

The loading indicator on tabs is now an hourglass.

Expected results:

The loading indicator should be that nice animation that it's always been.

Context: I'm actually one of those people that need reduced motion in order not to become sick browsing the web. However, being a person like that, I can tell you that a tiny loading indicator on a tab does not need to be replaced when the prefersReducedMotion is on. This decision should be reverted.

People who need reduced motion, need big movements and shift and slides to be disabled. A tiny animating icon is completely fine.

(In reply to Martijn from comment #1)

Context: I'm actually one of those people that need reduced motion in order not to become sick browsing the web. However, being a person like that, I can tell you that a tiny loading indicator on a tab does not need to be replaced when the prefersReducedMotion is on. This decision should be reverted.

People who need reduced motion, need big movements and shift and slides to be disabled. A tiny animating icon is completely fine.

it's not possible to generalize like this - the change was introduced after it was requested by multiple affected users. i think it's hard to justify why this particular animation should not be covered by a setting called "Turn off all unnecessary animations (where possible)" (windows) / "Reduce motion" (mac)...

See Also: → 1431237

I got migraines from the animation, and had to use user css to block it.

I wonder if there is some middle-ground here that would work better. There's no denying that a static icon suffers from being mistakenly representing frozen app. So what about an icon that updates only few times a second?

Old Firefox had a throbber of 10 or so small circles spinning around a shared center point (I believe it was either gif or apng image) but it could be recreated as SVG and rotated via css animation steps() function.

This would create minimal motion, but still clearly show that the UI is not frozen. I'll attach a demo of how it would look like. Or if you want to test it yourself you could get the demo css I used from here and load it via userChrome.css

To me, that looks a lot better than the back-and-forth one.

(In reply to [:philipp] from comment #2)

(In reply to Martijn from comment #1)

Context: I'm actually one of those people that need reduced motion in order not to become sick browsing the web. However, being a person like that, I can tell you that a tiny loading indicator on a tab does not need to be replaced when the prefersReducedMotion is on. This decision should be reverted.

People who need reduced motion, need big movements and shift and slides to be disabled. A tiny animating icon is completely fine.

it's not possible to generalize like this - the change was introduced after it was requested by multiple affected users. i think it's hard to justify why this particular animation should not be covered by a setting called "Turn off all unnecessary animations (where possible)" (windows) / "Reduce motion" (mac)...

True, generalizing was wrong. But mind you, a single switch to control all animations big and small, is generalizing in the exact same way, isn't it. I didn't realize people were actually affected by the throbber. Since I'm affected only by scrolling/swiping animations, I kind of assumed such a small throbber would not affect anyone. Apologies.

But, I don't think there should be a single master switch that turns all animations on or off. That is wrong to me. I want to turn off only the animations that affect me.

Turning off animations that don't affect me (like, currently, closing a tab, which is controlled by this setting as well) has an adverse effect. The browser feels choppy without it actually being choppy. Animations that don't affect me, are helpful in showing what happens, where something goes, etc.

(In reply to MarjaE from comment #3)

I got migraines from the animation, and had to use user css to block it.

Sorry to hear that. I didn't realize people were affected by the throbber. Apologies.
But for me, it adds value in showing an "active" loading process.

Component: Untriaged → Theme

I'd like finer-grained control. But about:preferences has a lot of accessibility and navigibility issues right now. So it's important to cover as many different needs as possible with as few settings as possible.

Please make this configurable, at least in about:config.

I'm a web developer working from home through Remote Desktop, which disables animations in Windows (since they're otherwise very sluggish over Remote Desktop). This doesn't mean I want the regular loading animation in Firefox disabled however; the static hourglass is in fact highly annoying!

I understand that the regular animation causes issues for some, so disabling it by default as it is now is ok, but I'd very much like a manual override for this, e.g. through a new setting in about:config.

(In reply to mozilla.bugzilla from comment #10)

Please make this configurable, at least in about:config.

You can create a ui.prefersReducedMotion numeric preference, and set it to 0 or 1 to override the system setting.

(In reply to Marco Bonardo [:mak] from comment #11)

(In reply to mozilla.bugzilla from comment #10)

Please make this configurable, at least in about:config.

You can create a ui.prefersReducedMotion numeric preference, and set it to 0 or 1 to override the system setting.

Awesome, thanks, works perfectly!

Status: UNCONFIRMED → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1650028

@Dão Should I make another bug to split out different animation preferences?

Feel free to but I don't see based on what criteria you'd split the preference. We don't intend to provide separate prefs for individual animations either.

Duplicate of this bug: 1661268
You need to log in before you can comment on or make changes to this bug.