Closed Bug 1661874 Opened 1 year ago Closed 1 year ago

More ColumnSet cleanup

Categories

(Core :: Layout: Columns, task)

task
Not set
normal

Tracking

()

RESOLVED FIXED
82 Branch
Tracking Status
firefox82 --- fixed

People

(Reporter: TYLin, Assigned: TYLin)

References

Details

Attachments

(4 files)

+++ This bug was initially created as a clone of Bug #1618646 +++

After supporting column-span, nsColumSetFrame isn't the top-level multicol container anymore. We can simplify its logic a bit.

Rename so that its naming is consistent with ReflowConfig::mColISize,
and to avoid confusion with ColumnBalanceData::mMaxBSize.

The support of this was added in
https://hg.mozilla.org/mozilla-central/rev/fb0790d28846

After supporting column-span, ColumnSetFrame isn't the top-level
multicol container anymore, and is not served as an abs.pos container.
Thus, we can simply the reflow code a bit.

Depends on D88697

I feel skipIncremental is hard to reasoning. It's easier to list all the
possible reasons that the child needs to be reflowed again.

Depends on D88698

nsColumnSetFrame's ComputedBSize() and ComputedMaxBSize() are always
NS_UNCONSTRAINEDSIZE.

Depends on D88699

Assignee: nobody → aethanyc
Status: NEW → ASSIGNED
Pushed by aethanyc@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/6bc1452132f5
Part 1 - Rename mColMaxBSize to mColBSize in ReflowConfig. r=heycam
https://hg.mozilla.org/integration/autoland/rev/d1bacf3c0f3f
Part 2 - Remove the support of ColumnSetFrame being an abs.pos container. r=heycam
https://hg.mozilla.org/integration/autoland/rev/84313d82b10a
Part 3 - Reverse the meaning of skipIncremental and rename it. r=heycam
https://hg.mozilla.org/integration/autoland/rev/cc4b6a85883f
Part 4 - Simplify the condition to set colData.mHasExcessBSize to true. r=heycam
You need to log in before you can comment on or make changes to this bug.