[ps] Mozilla fails to print 2nd webpage

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
P2
major
RESOLVED WORKSFORME
15 years ago
11 years ago

People

(Reporter: Renaud Manus, Unassigned)

Tracking

Trunk
Future
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.1b) Gecko/20020831
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.1b) Gecko/20020831

Mozilla is unable to print after printing a webpage.

The first print works but the second fails with the popup window 

------------------------------------
|Printer Error                     |
-----------------------------------|
|You cannot print while in preview |
------------------------------------

Reproducible: Always

Steps to Reproduce:
1.Go to http://www.deathfall.com/tutorials.php?op=showcontent&id=1&page=2
2.Print this page 
3.Then go to http://www.deathfall.com/tutorials.php?op=showcontent&id=1&page=3
4.Print this page
Actual Results:  
If you try to print this page, the error window is displayed

Expected Results:  
The page should be printed

Comment 1

15 years ago
Renaud Manus wrote:
> ------------------------------------
> |Printer Error                     |
> -----------------------------------|
> |You cannot print while in preview |
> ------------------------------------

This is a strong indicator that either the print engine is still busy or that
someone leaked the printer |nsIDeviceContext| ...

----

Works for me - I tested it with 2002-08-30-08-trunk on Solaris 2.7/SPARC (build
with Sun Workshop 7FCS) + Xprint module.
(Reporter)

Comment 2

15 years ago
I reproduced it with latest nightly build 2002090222

Comment 3

15 years ago
I get connection refused when trying to access either of the referenced pages.
(Reporter)

Comment 4

15 years ago
The symptom is different with BuildID 2002101922.
The first page prints correctly but the second page is not sent
to the printer and the error window "Prnter error" is not present either.

Comment 5

15 years ago
This issue should be fixed in 2003-01-14-trunk when using Mozilla's Xprint
module (this will still occur when using the PostScript module ;-(( ).
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

15 years ago
When will this release be available? 

The latest nightly build is from 12/12/02 :-(

Comment 7

15 years ago
Renaud Manus wrote:
> When will this release be available? 
> The latest nightly build is from 12/12/02 :-(

Known problem... ;-(
I am still waiting for an account to upload my Solaris nightlies (that's bug
188135 ("Request for ftp staging permission for Roland Mainz"))

For now I am uploading my Phoenix nightlies for Solaris/SPARC under
http://puck.informatik.med.uni-giessen.de/people/gisburn/work/mozilla/phoenix/nightly/
(script runs every 1-2 days, the nightly builds only get the spare CPU time of a
Ultra5/333MHz; account on a faster/idle box welcome :)

Updated

15 years ago
Priority: -- → P2
Target Milestone: --- → Future

Updated

15 years ago
Summary: Mozilla fails to print 2nd webpage → [ps] Mozilla fails to print 2nd webpage

Updated

11 years ago
Assignee: rods → printing
QA Contact: sujay
(Reporter)

Comment 8

11 years ago
Works for me with firefox.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.