Closed Bug 16623 Opened 23 years ago Closed 23 years ago

RFE: [4.xP] Is IMG filename wanted as ALT of last resort?

Categories

(Core :: Layout, enhancement, P3)

x86
Windows NT
enhancement

Tracking

()

VERIFIED DUPLICATE of bug 5764

People

(Reporter: sidr, Assigned: troy)

Details

Attachments

(1 file)

Summary:
Currently, if no ALT is given (or if the ALT is an empty string, see Bug 16619)
for an IMG that cannot be loaded, the filename of the IMG is used as an
ALT of last resort.  Is this really what is wanted

In the attached example, there are 66 gif flies that cannot be loaded,
for the usual reason: all have partial URLs that only resolve to
the proper full URLs if the page is received directly from the originating
server (the attachment may take over a minute to display).

Every second line of the main table contains "1x1trans," the name of MSN's
single-pixel transparent gif, instead of the requested nothingness on tan
as a spacer. It looks UGLY.

Now, I can also think of reasons why it might be handy to see the name of the
unloaded file - to spot typos in situ while coding HTML, if nothing else.

But for pages that are finished but cannot be displayed with all their images,
this is worse than the infamous Bug 5821: the same amount of extra space
appears in table cells, but this time it gets filled with extraeous text.

Communicator in the same situation appears to display no ALT text.

So, which is to be: a new-and-sometimes-useful behaviour or the 4.xP
behaviour?
Status: NEW → RESOLVED
Closed: 23 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 5764 ***
Status: RESOLVED → VERIFIED
QA Contact: petersen → py8ieh=bugzilla
According to HTML4, we _do_ want to use the filename if the ALT attribute is
not given. If the author intended the image to be decorative and thus not be
displayed at all if it could not be downloaded, then he should have used an
empty alt attribute.
You need to log in before you can comment on or make changes to this bug.