Printing sometimes causes computer to restart

VERIFIED DUPLICATE of bug 168385

Status

()

Core
Printing: Output
--
major
VERIFIED DUPLICATE of bug 168385
16 years ago
15 years ago

People

(Reporter: Jason Silverstein, Assigned: rods (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020721
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020721

When attempting to print a webpage on Mozilla, the computer will sometimes cause
the computer to restart in the middle of what appears to be its transferring of
data to the printer. I have not had this problem with any other application, so
I can only assume it's a problem with Mozilla.

Possibly pertinent information:
Motherboard - Abit KG7-RAID
Processor - Athlon 1.33Ghz (266MHz FSB)
OS - Windows 2000 Professional, running LiteStep Desktop
Printer: Samsung ML-4500 Laser Printer

Reproducible: Sometimes

Steps to Reproduce:
1. Just print a page with default settings.
2.
3.

Actual Results:  
Sometimes, it prints as normal. Other times, the computer restarts.

Expected Results:  
It should just print.

Comment 1

16 years ago
similar: bug 160337
Depends on: 160337
(Reporter)

Comment 2

16 years ago
Er, Win2k SP2 != WinNT 4.0 SP5, afaik
(Assignee)

Comment 3

16 years ago
Does a more recent version of Mozilla do this? Or the final release of Netscape?

Comment 4

16 years ago
DUP of bug 160337 ? can someone DUP this ?
(Reporter)

Comment 5

16 years ago
rods@netscape.com said:
> Does a more recent version of Mozilla do this? Or the final release of Netscape?

I'm having it happen on Mozilla 1.1b.

Comment 6

15 years ago
WFM with 2002111108/trunk/win2k.

reporter (Jason): can you reproduce this bug with a recent build of mozilla (for
example, 1.2beta)? if so, please comment again with details. if not, please
resolve this bug as WORKSFORME. thanks.

Comment 7

15 years ago
I am also having this or a very similar problem.  I think that Bug 168385 is
similar, so I don't know for sure which is causing my crashes.  I have Mozilla
1.1 running on three computers.  The crash happens on two that are both Win2K
(one SP2 and one SP3) that are printing to a Xerox WC 390 through my wireless
network.  The crash does not happen on the one that is Win98SE that has the WC
390 connected to LPT:1.  

This does not consistently happen for me.  It seems to happen more often with
longer pages and also more often when the computers (both laptops) are farther
away from the the hub (lower bandwidth/larger latency).  From what I was
experiencing, I thought that perhaps this was related to 169689.  I just,
however, experienced the same crash (on the WIN2K sp 2 machine) using a recent
(11/01/02) nightly build (Build ID: 2002110104), which I think has the fix for
169689 in it.

The blue screen says:

*** STOP: 0x0000001E (0xC0000005, 0x8046A7A2, 0x00000000, 0x1515150F)
K_MODE_EXCEPTION_NOT_HANDLED

*** Address 8046A7A2 base at 80400000, DateStamp 3ad7ad60 - ntoskrnl.exe

I also have the small (64KB) memory dump that I can attach if that would be helpful.

I know there are a lot of bugs to be stomped, but this one is very close to
having my wife going back to IE and I'd really rather avoid that.

If you need help testing or more information, I'm willing to help.  I just wish
I were enough of a programmer to try and figure this one out myself.

Comment 8

15 years ago
well a good start would be to test with a recent build of mozilla - 1.1 is very
old compared to the current code that's being worked on. if you don't want to
try a nightly build, 1.2 final should be out soon (a few days), so you could
retry with that, and then post here again with results.

quite unlikely that mozilla would bring your system down like that on its own,
so quite possibly mozilla is tickling a bug in the printer driver - maybe you
could try an updated, or alternative, printer driver?

Comment 9

15 years ago
Right.  I did try it (and reproduce it) with the 11/01/02 nightly build (Build
ID: 2002110104).  I will see what I can do about printer driver versions.  

Comment 10

15 years ago
I tried it again with the current (2002111108) nightly build.  The printer I am
using (Xerox WC 390) has two driver versions for Win2K available on their web
site.  I tried them both (1.1.1 and 1.1.2) and reliable crashed the system as
described.  When I print the Mozilla start page is one that crashes.  

I can see why assuming that this is a drive bug would be reasonable.  However, I
print from a number of applications and this is the only one the gives me a BSOD
when I do it.  

I'm going to post this comment to 166249, 160337, and 168385 because it may be
relevant to one or more of these bugs.

I am open to suggestions on additional testing I can do to help nail this down.

Comment 11

15 years ago
This sounds almost exactly like bug 168385. I'm going to update bug 168385 with
some of the data here, and mark this one a duplicate of that one. If bug 168385
becomes resolved, and this bug is not fixed, then please re-open this bug.

-M

*** This bug has been marked as a duplicate of 168385 ***
URL: N/AN/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 12

15 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.