Closed Bug 1662518 Opened 1 year ago Closed 1 year ago

Use dummy result for nsIPrinter::SupportsColor with older CUPS

Categories

(Core :: Printing: Setup, enhancement, P1)

Firefox 81
Unspecified
Linux
enhancement

Tracking

()

RESOLVED FIXED
82 Branch
Tracking Status
firefox81 --- fixed
firefox82 --- fixed

People

(Reporter: alaskanemily, Assigned: alaskanemily)

References

(Regressed 1 open bug)

Details

(Whiteboard: [print2020_v81])

Attachments

(3 files)

Based on the investigation in 1660658, it appears that older CUPS returns incorrect values for color support. We should add a version check for the printer's server, and if it is before a threshold just return true to allow color printing.

We will use this for CUPS version parsing.

Pushed by emcdonough@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f7b557363e1b
part 1 - Add semver to gkrust_util r=emilio
https://hg.mozilla.org/integration/autoland/rev/43f006fdc369
part 2 - Get CUPS server version info for each printer. r=emilio,jwatt
https://hg.mozilla.org/integration/autoland/rev/75e7a560323a
part 3 - Use a dummy value for nsPrinterCUPS::SupportsColor if CUPS is older than 2.2 r=emilio,jwatt

Comment on attachment 9173458 [details]
Bug 1662518 part 3 - Use a dummy value for nsPrinterCUPS::SupportsColor if CUPS is older than 2.2

Beta/Release Uplift Approval Request

  • User impact if declined: Users with older versions of CUPS (in particular Ubuntu 16) will likely be unable to choose color printing in the new print UI for some printers.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Medium
  • Why is the change risky/not risky? (and alternatives if risky): We haven't really had the time to properly test if this actually fixes bug 1660658, but it shouldn't cause serious problems if it turns out to be unnecessary. At worst, some black-and-white only printers on very old CUPS (such as on Ubuntu 16, but not Ubuntu 18+) would appear to be color during print preview. It will only affect the new printing UI in any case.
  • String changes made/needed:
Attachment #9173458 - Flags: approval-mozilla-beta?
Attachment #9173456 - Flags: approval-mozilla-beta?
Attachment #9173457 - Flags: approval-mozilla-beta?

This cannot be verified as resolved until bug 1662946 is corrected as the hang condition renders it impossible to use the print function at all.

Comment on attachment 9173456 [details]
Bug 1662518 part 1 - Add semver to gkrust_util

Approved for 81.0b6.

Attachment #9173456 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9173457 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9173458 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Regressions: 1668813
You need to log in before you can comment on or make changes to this bug.