Closed Bug 1662691 Opened 1 year ago Closed 1 year ago

Range error (for invalid custom range) is displayed for “All” range as well

Categories

(Toolkit :: Printing, defect, P2)

defect

Tracking

()

VERIFIED FIXED
82 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox80 --- unaffected
firefox81 --- verified
firefox82 --- verified

People

(Reporter: emilghitta, Assigned: emalysz)

References

(Blocks 2 open bugs)

Details

(Keywords: regression, Whiteboard: [print2020_v81] [old-ui-])

Attachments

(2 files)

Attached image AllError.gif

Affected versions

  • 82.0a1 (BuildId:20200901214943)
  • 81.0b5 (BuildId:20200901203141)

Affected platforms

  • Windows 10 64bit
  • Ubuntu 18.04 64bit
  • macOS 10.14

Steps to reproduce

  1. Launch Firefox.
  2. Access the following link.
  3. Select an invalid Custom page range.
  4. Switch to “all” page range fast.

Expected result

  • The invalid page range error is not displayed for the “all” range even if the user has fastly changed from an invalid custom range to the “all” range.

Actual result

  • The invalid page range error remains displayed even if the “all” range is selected.

Regression Window

Additional Information

  • For further information regarding this issue please observe the attached screencast.
  • [Suggested Severity] S3 or S4
Blocks: 133787, 1658287

(Emma probably knows what the fix here is…)

(Also, I can't reproduce this on macOS on the Nightly I just installed (82.0a1 (2020-09-02)), and I know we're doing some work in this area, so it might have been fixed by something that just landed. Specifically bug 1662145 looks similar.)

Odd...I can reproduce this issue using Firefox 82.0a1 (BuildId:20200902095359) on macOS 10.14..the trick is to change from custom to all pretty fast.

Assignee: nobody → emalysz
Severity: -- → S4
Priority: -- → P2
Status: NEW → ASSIGNED
Pushed by nerli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/682c2791c258
ensure we clear the error timeout when switching to 'all' page range r=sfoster

Comment on attachment 9173664 [details]
Bug 1662691, ensure we clear the error timeout when switching to 'all' page range

Beta/Release Uplift Approval Request

  • User impact if declined: The user may incorrectly see an error message
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: 1. Open firefox with printing.tab_modal.enabled turned on
  1. Command P
  2. Change the page range from custom to all
  3. enter an invalid number in the range
  4. In less than half a second (before the error shows), go from "custom" to "all"
  5. Notice the error does not appear
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): No strings
  • String changes made/needed: n/a
Attachment #9173664 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch

This issue is verified fixed using Firefox 82.0a1 (BuildId:20200903094553) on Windows 10 64bit, macOS 10.14 & Ubuntu 18.04 64bit.

Leaving a ni? on myself and the qe-verify+ until this gets verified in beta as well.

Status: RESOLVED → VERIFIED
Flags: needinfo?(emil.ghitta)

Comment on attachment 9173664 [details]
Bug 1662691, ensure we clear the error timeout when switching to 'all' page range

Approved for 81.0b6.

Attachment #9173664 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

This is verified fixed using Firefox 81.0b7 (BuildId:20200906164749) on Windows 10 64bit, macOS 10.14 & Ubuntu 18.04 64bit.

Flags: qe-verify+
Flags: needinfo?(emil.ghitta)
You need to log in before you can comment on or make changes to this bug.