Closed Bug 1662983 Opened 1 year ago Closed 1 year ago

Roboto web font not rendering properly

Categories

(Core :: Layout: Text and Fonts, defect)

Firefox 81
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: web, Unassigned, NeedInfo)

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:81.0) Gecko/20100101 Firefox/81.0

Steps to reproduce:

load youtube.com, or other site which uses the Roboto web font e.g.
https://support.google.com/domains/answer/6069273

Sites which use my local copy of Roboto do not seem to be affected

Actual results:

See screenshot

Expected results:

Normal font rendering

Please provide clear and self-contained steps to reproduce how exactly something is loaded somewhere - thanks!

Also, does this happen in safe mode without any add-ons enabled, in a fresh and new user profile?

Flags: needinfo?(web)

"Restart with addons disabled" solved the problem for that session, until I quit the browser and restarted normally, when the problem returned. Manually disabling all extensions did not solve the problem then

Flags: needinfo?(web)
Attached file HAR file
This is the HAR for the request for the web font

The problem appears to have been solved in 81.0b7

Hi Web,

Thanks for confirming this issue is no longer reproducible on your end.
Please confirm if we can mark this ticket as resolved. (You can always reopen this bug if you have any troubles.)

Regards, Clara

Flags: needinfo?(web)

yes please close

Flags: needinfo?(web)
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Component: Untriaged → Layout: Text and Fonts
Product: Firefox → Core
Resolution: --- → WORKSFORME

Unfortunately, this has returned in 82.0b2

Can you attach your about:support information?

Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(web)
Resolution: WORKSFORME → ---
Attached file about:support

WebRender seems to be enabled by default for you now, is there any chance that's why it came back?

It's possible?

a few observations:

Uninstalling local roboto fonts, then reloading youtube.com changed the nature of the bug. before uninstalling and reloading, the video thumbnail subtitles were corrupted, after uninstalling and reloading the video subtitles were fine, but the video titles were corrupted.

Then, unsetting video title font-weight via dev tools fix its rendering.

Then, installing roboto locally again with the latest version from google fonts website, then restarting firefox has - so far - solved the rendering on youtube.com.

Perhaps the particular version of Roboto that you had installed previously tickled a WebRender bug. I'm going to mark this WFM again, but please do re-open if it comes back again, and we can try to work out what's going on with the specific font files. Thanks!

Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.