Closed Bug 1663072 Opened 2 years ago Closed 2 years ago

Intermittent toolkit/components/printing/tests/browser_modal_print.js | Test timed out - | Found a tab after previous test timed out:

Categories

(Toolkit :: Printing, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1663071

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure)

Filed by: btara [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=314825496&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/ToS-hRExTU6znpaSGh2C3g/runs/0/artifacts/public/logs/live_backing.log


[task 2020-09-03T20:35:26.710Z] 20:35:26     INFO - TEST-START | toolkit/components/printing/tests/browser_modal_print.js
[task 2020-09-03T20:35:27.354Z] 20:35:27     INFO - GECKO(31687) | [Parent 31687, Main Thread] WARNING: g_object_ref: assertion 'G_IS_OBJECT (object)' failed: 'glib warning', file /builds/worker/checkouts/gecko/toolkit/xre/nsSigHandlers.cpp, line 135
[task 2020-09-03T20:35:27.354Z] 20:35:27     INFO - GECKO(31687) | (firefox:31687): GLib-GObject-CRITICAL **: 20:35:27.345: g_object_ref: assertion 'G_IS_OBJECT (object)' failed
[task 2020-09-03T20:35:27.901Z] 20:35:27     INFO - GECKO(31687) | [Parent 31687, Main Thread] WARNING: g_object_ref: assertion 'G_IS_OBJECT (object)' failed: 'glib warning', file /builds/worker/checkouts/gecko/toolkit/xre/nsSigHandlers.cpp, line 135
[task 2020-09-03T20:35:27.901Z] 20:35:27     INFO - GECKO(31687) | (firefox:31687): GLib-GObject-CRITICAL **: 20:35:27.891: g_object_ref: assertion 'G_IS_OBJECT (object)' failed
[task 2020-09-03T20:35:28.685Z] 20:35:28     INFO - GECKO(31687) | [Parent 31687, Main Thread] WARNING: g_object_ref: assertion 'G_IS_OBJECT (object)' failed: 'glib warning', file /builds/worker/checkouts/gecko/toolkit/xre/nsSigHandlers.cpp, line 135
[task 2020-09-03T20:35:28.686Z] 20:35:28     INFO - GECKO(31687) | (firefox:31687): GLib-GObject-CRITICAL **: 20:35:28.678: g_object_ref: assertion 'G_IS_OBJECT (object)' failed
[task 2020-09-03T20:35:29.164Z] 20:35:29     INFO - GECKO(31687) | [Parent 31687, Main Thread] WARNING: g_object_ref: assertion 'G_IS_OBJECT (object)' failed: 'glib warning', file /builds/worker/checkouts/gecko/toolkit/xre/nsSigHandlers.cpp, line 135
[task 2020-09-03T20:35:29.164Z] 20:35:29     INFO - GECKO(31687) | (firefox:31687): GLib-GObject-CRITICAL **: 20:35:29.149: g_object_ref: assertion 'G_IS_OBJECT (object)' failed
[task 2020-09-03T20:36:11.712Z] 20:36:11     INFO - TEST-INFO | started process screentopng
[task 2020-09-03T20:36:12.049Z] 20:36:12     INFO - TEST-INFO | screentopng: exit 0
[task 2020-09-03T20:36:12.050Z] 20:36:12     INFO - Buffered messages logged at 20:35:26
[task 2020-09-03T20:36:12.050Z] 20:36:12     INFO - Entering test bound testModalPrintDialog
[task 2020-09-03T20:36:12.051Z] 20:36:12     INFO - Buffered messages logged at 20:35:27
[task 2020-09-03T20:36:12.051Z] 20:36:12     INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.com/browser/toolkit/components/printing/tests/simplifyArticleSample.html" line: 0}]
[task 2020-09-03T20:36:12.051Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | There are no print dialogs - 
[task 2020-09-03T20:36:12.052Z] 20:36:12     INFO - Global property added while loading chrome://global/content/printUtils.js: gFocusedElement
[task 2020-09-03T20:36:12.053Z] 20:36:12     INFO - Global property added while loading chrome://global/content/printUtils.js: PRINT_TAB_MODAL
[task 2020-09-03T20:36:12.053Z] 20:36:12     INFO - Global property added while loading chrome://global/content/printUtils.js: PRINT_ALWAYS_SILENT
[task 2020-09-03T20:36:12.054Z] 20:36:12     INFO - Global property added while loading chrome://global/content/printUtils.js: PromptUtils
[task 2020-09-03T20:36:12.054Z] 20:36:12     INFO - Console message: [JavaScript Warning: "printing.preview_opened_tm - Cannot record the scalar in the current process."]
[task 2020-09-03T20:36:12.055Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | There is one print dialog - 
[task 2020-09-03T20:36:12.055Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | The dialog exists - 
[task 2020-09-03T20:36:12.055Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | The URL of the browser is the one we expect - 
[task 2020-09-03T20:36:12.055Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | The dialog exists - 
[task 2020-09-03T20:36:12.056Z] 20:36:12     INFO - Console message: [JavaScript Warning: "Key event not available on some keyboard layouts: key=“r” modifiers=“accel,alt” id=“key_toggleReaderMode”" {file: "chrome://mochikit/content/tests/SimpleTest/EventUtils.js" line: 1192}]
[task 2020-09-03T20:36:12.056Z] 20:36:12     INFO - Console message: [JavaScript Warning: "Key event not available on some keyboard layouts: key=“i” modifiers=“accel,alt,shift” id=“key_browserToolbox”" {file: "chrome://mochikit/content/tests/SimpleTest/EventUtils.js" line: 1192}]
[task 2020-09-03T20:36:12.056Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | There are no print dialogs - 
[task 2020-09-03T20:36:12.056Z] 20:36:12     INFO - Leaving test bound testModalPrintDialog
[task 2020-09-03T20:36:12.057Z] 20:36:12     INFO - Entering test bound testPrintMultiple
[task 2020-09-03T20:36:12.063Z] 20:36:12     INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.com/browser/toolkit/components/printing/tests/simplifyArticleSample.html" line: 0}]
[task 2020-09-03T20:36:12.063Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | There are no print dialogs - 
[task 2020-09-03T20:36:12.063Z] 20:36:12     INFO - Console message: [JavaScript Warning: "printing.preview_opened_tm - Cannot record the scalar in the current process."]
[task 2020-09-03T20:36:12.063Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | There is one print dialog - 
[task 2020-09-03T20:36:12.065Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | The dialog exists - 
[task 2020-09-03T20:36:12.065Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | The URL of the browser is the one we expect - 
[task 2020-09-03T20:36:12.065Z] 20:36:12     INFO - Buffered messages logged at 20:35:28
[task 2020-09-03T20:36:12.065Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | There is one print dialog - 
[task 2020-09-03T20:36:12.065Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | There is one print dialog - 
[task 2020-09-03T20:36:12.065Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | There is one print dialog - 
[task 2020-09-03T20:36:12.065Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | The dialog exists - 
[task 2020-09-03T20:36:12.066Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | The URL of the browser is the one we expect - 
[task 2020-09-03T20:36:12.066Z] 20:36:12     INFO - Leaving test bound testPrintMultiple
[task 2020-09-03T20:36:12.066Z] 20:36:12     INFO - Entering test bound testCancelButton
[task 2020-09-03T20:36:12.067Z] 20:36:12     INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.com/browser/toolkit/components/printing/tests/simplifyArticleSample.html" line: 0}]
[task 2020-09-03T20:36:12.071Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | There are no print dialogs - 
[task 2020-09-03T20:36:12.072Z] 20:36:12     INFO - Console message: [JavaScript Warning: "printing.preview_opened_tm - Cannot record the scalar in the current process."]
[task 2020-09-03T20:36:12.072Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | There is one print dialog - 
[task 2020-09-03T20:36:12.073Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | The dialog exists - 
[task 2020-09-03T20:36:12.073Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | Got the cancel button - 
[task 2020-09-03T20:36:12.073Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | The dialog exists - 
[task 2020-09-03T20:36:12.074Z] 20:36:12     INFO - Console message: [JavaScript Warning: "printing.preview_cancelled_tm - Cannot record the scalar in the current process."]
[task 2020-09-03T20:36:12.074Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | There are no print dialogs - 
[task 2020-09-03T20:36:12.074Z] 20:36:12     INFO - Leaving test bound testCancelButton
[task 2020-09-03T20:36:12.079Z] 20:36:12     INFO - Entering test bound testTabOrder
[task 2020-09-03T20:36:12.080Z] 20:36:12     INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.com/browser/toolkit/components/printing/tests/simplifyArticleSample.html" line: 0}]
[task 2020-09-03T20:36:12.080Z] 20:36:12     INFO - Buffered messages logged at 20:35:29
[task 2020-09-03T20:36:12.081Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | There are no print dialogs - 
[task 2020-09-03T20:36:12.081Z] 20:36:12     INFO - Console message: [JavaScript Warning: "printing.preview_opened_tm - Cannot record the scalar in the current process."]
[task 2020-09-03T20:36:12.081Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | There is one print dialog - 
[task 2020-09-03T20:36:12.081Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | The dialog exists - 
[task 2020-09-03T20:36:12.081Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | The dialog exists - 
[task 2020-09-03T20:36:12.081Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | Initial focus on printer picker - 
[task 2020-09-03T20:36:12.081Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | The dialog exists - 
[task 2020-09-03T20:36:12.081Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | Got the print preview browser - 
[task 2020-09-03T20:36:12.082Z] 20:36:12     INFO - TEST-PASS | toolkit/components/printing/tests/browser_modal_print.js | Print preview focused after shift+tab - 
[task 2020-09-03T20:36:12.082Z] 20:36:12     INFO - Buffered messages finished
[task 2020-09-03T20:36:12.082Z] 20:36:12     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/printing/tests/browser_modal_print.js | Test timed out - 
[task 2020-09-03T20:36:12.082Z] 20:36:12     INFO - GECKO(31687) | MEMORY STAT vsizeMaxContiguous not supported in this build configuration.
[task 2020-09-03T20:36:12.082Z] 20:36:12     INFO - GECKO(31687) | MEMORY STAT | vsize 3040MB | residentFast 305MB | heapAllocated 101MB
[task 2020-09-03T20:36:12.083Z] 20:36:12     INFO - TEST-OK | toolkit/components/printing/tests/browser_modal_print.js | took 45017ms
[task 2020-09-03T20:36:12.083Z] 20:36:12     INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-09-03T20:36:12.083Z] 20:36:12     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/printing/tests/browser_modal_print.js | Found a tab after previous test timed out: http://example.com/browser/toolkit/components/printing/tests/simplifyArticleSample.html - 
[task 2020-09-03T20:36:12.084Z] 20:36:12     INFO - checking window state
[task 2020-09-03T20:36:12.084Z] 20:36:12     INFO - TEST-START | toolkit/components/printing/tests/browser_modal_resize.js
[task 2020-09-03T20:36:12.591Z] 20:36:12     INFO - GECKO(31687) | [Parent 31687, Main Thread] WARNING: g_object_ref: assertion 'G_IS_OBJECT (object)' failed: 'glib warning', file /builds/worker/checkouts/gecko/toolkit/xre/nsSigHandlers.cpp, line 135
[task 2020-09-03T20:36:12.591Z] 20:36:12     INFO - GECKO(31687) | (firefox:31687): GLib-GObject-CRITICAL **: 20:36:12.585: g_object_ref: assertion 'G_IS_OBJECT (object)' failed
[task 2020-09-03T20:36:13.745Z] 20:36:13     INFO - GECKO(31687) | MEMORY STAT | vsize 3026MB | residentFast 294MB | heapAllocated 97MB
[task 2020-09-03T20:36:13.745Z] 20:36:13     INFO - TEST-OK | toolkit/components/printing/tests/browser_modal_resize.js | took 1918ms
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1663071
You need to log in before you can comment on or make changes to this bug.