Closed Bug 1663412 Opened 1 year ago Closed 1 year ago

Crash in [@ cupsGetDestMediaByName]

Categories

(Core :: Print Preview, defect, P1)

Unspecified
macOS
defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox80 --- unaffected
firefox81 --- disabled
firefox82 --- verified

People

(Reporter: emilghitta, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: crash, Whiteboard: [print2020_v82][old-ui-][Fixed by 1661157])

Crash Data

Crash report: https://crash-stats.mozilla.org/report/index/65aea66e-e3f8-4ba3-8435-cb5590200907

Top 10 frames of crashing thread:

0 libcups.2.dylib cupsGetDestMediaByName 
1 libcups.2.dylib cupsGetDestMediaDefault 
2 XUL nsPrinterCUPS::DefaultSettings const widget/nsPrinterCUPS.cpp:45
3 XUL void mozilla::SpawnPrintBackgroundTask<nsPrinterBase, mozilla::PrintSettingsInitializer, > const widget/PrintBackgroundTask.h:53
4 XUL mozilla::detail::RunnableFunction<void mozilla::SpawnPrintBackgroundTask<nsPrinterBase, mozilla::PrintSettingsInitializer, > xpcom/threads/nsThreadUtils.h:577
5 XUL nsThreadPool::Run xpcom/threads/nsThreadPool.cpp:299
6 XUL nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1234
7 XUL mozilla::ipc::MessagePumpForNonMainThreads::Run ipc/glue/MessagePump.cpp:302
8 XUL MessageLoop::Run ipc/chromium/src/base/message_loop.cc:309
9 XUL nsThread::ThreadFunc xpcom/threads/nsThread.cpp:442

Steps are the same as the ones for Bug 1663410 but this seems to have a different signature

Severity: -- → S2
Component: Printing → Print Preview
Priority: -- → P1
Product: Toolkit → Core
Whiteboard: [print2020_v81][old-ui-]
Whiteboard: [print2020_v81][old-ui-] → [print2020_v82][old-ui-]

Similar to bug 1663410, this should be resolved as part of the fix for bug 1661157. Emil: Can you verify as part of your next test run?

Flags: needinfo?(emil.ghitta)

I am unable to reproduce this crash using Firefox 82.0a1 (BuildId:20200911093056) on macOS 10.14

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(emil.ghitta)
Resolution: --- → FIXED
Whiteboard: [print2020_v82][old-ui-] → [print2020_v82][old-ui-][Fixed by 1661157]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.